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Introduction 
 
Welcome to Tycho.  This software is designed to facilitate the detection and measurement of asteroids, 
comets, and variable stars.  It also supports a technique known as Synthetic Tracking, which enables the 
detection of very faint objects.  This is achieved by using the data from many exposures (a minimum of 
11) and applying the stacking technique for an improved signal-to-noise ratio.  Because the exposures 
are stacked in thousands of different possible combinations, synthetic tracking allows for the detection 
of faint objects even when the motion of the object is unknown.  This is made possible by using the 
graphics processing unit (GPU) on your computer. 
 
Starting with v5.3, it is now possible to run the software without a dedicated graphics card.  However, it 
is still recommended to equip your machine with a dedicated graphics card if you intend to perform 
synthetic tracking.  Most other functionality can be done acceptably without GPU acceleration. 
 

System Requirements 
 

• CPU: Intel Core i5 4590 or better 

• RAM: 8GB or more 

• Windows 7 SP1 or better 

 
Terminology 
 

Term/Acronym Definition 

CPU Central Processing Unit 
Your machine has one or more CPUs.  A CPU is designed to carry out instructions in 
a procedural fashion (one instruction at a time).  This is ideal for database 
transactions, spreadsheet functions, and so forth. 

GPU Graphics Processing Unit 
Your machine may have one or more GPUs.  A GPU excels at performing a single 
instruction in a massively parallel fashion (applying the same instruction across a 
large amount of data). 

Dedicated GPU A dedicated GPU is one that has its own source of video memory.  Such cards are 
typically much more powerful than their “integrated” counterparts. 

Integrated GPU An integrated GPU does not have its own memory.  Instead, it uses the available 
memory from the system, and is much less powerful than a dedicated GPU. 

OpenCL Open Compute Language 
One of the languages that can interface with a graphics processor is called OpenCL.  
This is a cross-platform language, meaning that it can work on both AMD and 
NVIDIA graphics cards. 
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First Time Setup 
 

Enable GPU Acceleration (if available) 
 
By default, Tycho will be installed to operate in “CPU mode”, with no GPU acceleration.  If your system 
has a dedicated video card (GPU), such as NVIDIA or AMD, then it is recommended to enable GPU 
acceleration.  This is accomplished by going to OpenCL->Device Selector from the main menu. 
 

 
Figure 1 - OpenCL Device Selector 

 
Troubleshooting 

1) If you get an error message when choosing a GPU device, make sure you have the latest drivers 
installed for your graphics card.  If after updating drivers you continue to get an error, try 
renaming the provided “OpenCL.dll” file that comes with Tycho to “OpenCL.dll_old” so that 
Tycho will use the OpenCL library provided by your system.  The provided DLL file is located in 
C:\Program Files\Tycho 

2) If the program unexpectedly quits when checking the box to enable GPU acceleration, it is likely 
due to having Intel UHD 630 graphics drivers installed alongside the dedicated NVIDIA or AMD 
drivers.  To remedy this, you can go to Device Manager and disable the Intel graphics driver.  
This can be done by opening Control Panel, choosing Device Manager, and under the “Display 
Adapters” section, right-click on the Intel UHD 630 device and choose “Properties”.  Then, on 
the “Driver” tab, click the “Disable” button. 

 
  



 

7 
 

Configure Report Parameters 
 
The report parameters are used to specify the persons involved in the acquisition and measurement of 
the asteroid image data. 
 
Navigate to Settings->Report Parameters and adjust the settings as needed: 
 

Submitter: Specify the name of the 
person submitting the reports. 
 
Observer: Specify the name of the 
person who acquired the images. 
 
Measurer: Specify the name of the 
person who processed and generated 
the astrometric and photometric 
measurements. 
 
Override: Check this box if you want to 
replace the ‘observer’ field with a 
value supplied in the FITS header. 
 
Contact Email: Specify a contact email 
for ALCDEF (lightcurve) submissions. 
 
Email address(es) for AC2 line: You 
can specify notification email 
addresses for MPC submissions.  Use a 
comma to separate multiple 
addresses. 
 
 

 
 
 

Omit Magnitude Information: These setting apply only to observations generated via “Verify Track”.     
 
Typically, if you wish to share discovery credit with another person, you would designate one person as 
the “Observer”, and the other person as the “Measurer”. 
 
All names should be formatted as first initial followed by last name, e.g., “J. Smith”. 
 
“Make these settings unique to the active observatory”:  Check this box if you wish to have unique 
report parameters for the active observatory.  For example, you might use Tycho for multiple 
observatories, and if you want them to use different reports, you can check this box.  Otherwise, if 
unchecked, they will all share a common set of report parameters. 

  

Figure 2 - Report Parameters 
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Configure Observatory Information 
 
In order to generate reports that can be submitted to the Minor Planet Center (MPC), it is necessary to 
provide some information about the observatory that captured the images.  Navigate to Settings-
>Observatory from the main menu.  Then choose Action->Add Observatory, as shown in Figure 3. 
 

 
Figure 3 - Observatory Configuration 

 
Label: Give the observatory a label so that 
you can refer to it later. 
 
Observatory Status: If the observatory 
already has a code from the MPC, choose 
“Already have an MPC code”.  If the 
observatory is applying for a new MPC 
code, choose “Applying for a new MPC 
code”.  If the observatory is temporary 
(such as a mobile location), choose 
“Temporary”. 
 
Location of the Observatory: Populate 
these fields as appropriate.  If the 
observatory has an MPC code, you can 
click “Apply location from MPC code” to 
populate the fields automatically.  You 
may need to update the “ObsCodes” file 
(Settings->ObsCodes). 
 
Telescope: Specify the type and aperture 
of the telescope, as well as its focal ratio. 
  

Figure 4 - Add New Observatory 
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Specify Settings for Camera 
 
Click “Next…” to proceed to the camera details for the new observatory. 
 

 
Figure 5 - Camera Details 

 
DATE-OBS: In order to make accurate observations, it is critical that you specify the correct setting for 
the time information provided by the camera.  Most cameras typically generate a “DATE-OBS” keyword 
in the FITS header of the image that refers to the beginning of the exposure.  However, some newer 
CMOS cameras may specify a “DATE-OBS” timestamp that refers to the end of exposure. 
 
Offset: If you know that the DATE-OBS timestamp is off by a fixed amount, you can specify a time offset 
here.  However, it is preferred that you fix the clock to be accurate in the first place, if possible. 
 
rmsTime: Random uncertainty in observation time.  Used only for ADES reports.  Optional. 
 
uncTime: Estimated systematic time error.  Used only for ADES reports.  Optional. 
 
Precision: For very fast-moving objects (satellites, very close NEOs), it may be necessary to use extra 
precision in the timestamp field.  Note: the MPC does not allow most observatories to use extra 
precision in the position (RA/Dec) field. 
 
CCD Characteristics: These parameters are used for SNR calculation. 
 
Finally, click “OK” and the new observatory will appear in the list of observatories.  To make the 
observatory the active observatory, right-click on it and choose “Make Active” from the pop-up menu 
that appears. 
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If you ever need to modify the observatory information, simply right-click the observatory in the list and 
choose “Edit…” from the pop-up menu that appears. 
 
If there are multiple cameras in use by the same observatory, with different time settings, then you can 
simply add additional observatories to the list with the same location data but different time settings.  
Assign these observatories different labels so as to distinguish between them internally. 
 
In essence, an “observatory” in this context refers to a set of configuration values that can be applied to 
a set of images.  As a result, the “Observatory Configuration” window allows you to easily switch 
between different configurations by right-clicking on the desired configuration and choosing “Make 
Active”. 
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Configure the Find_Orb Software 
 
The primary purpose of Tycho is to detect and measure asteroids.  After you have generated 
measurements, it is generally desirable to compare them with other measurements for validation.  The 
“Find_Orb” software, written by Bill Gray, is quite useful in this regard. 
 
If you have not already done so, please download the modified version of the Find_Orb software from 
the Tycho website: 
 
https://www.tycho-tracker.com/download 
 
Also, do not place Find_Orb in the root directory (C:\), as that would require elevated privileges.  
Instead, place it in a folder such as the Desktop, e.g., C:\Users\Daniel\Desktop\find_o64\. 
 
Once you have downloaded Find_Orb, navigate to Settings->Find_Orb and configure the file path similar 
to how it is presented in Figure 6: 
 

 
Figure 6 - Configuring the Find_Orb Software 

 
When finished, click “OK” to save the settings.  

https://www.tycho-tracker.com/download
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Configure the Known Object Database 
 
The “Known Object” database is useful to determine which detections match up with already known 
objects.  It can be configured by going to Settings->Known Objects from the main menu. 
 

 
Figure 7 - Known Object Database Configuration 

 
In the top-left there is a button “Download MPCORB.DAT”.  Click this button to download the orbital 
elements of over 1 million asteroids (approximately 60MByte in size).  When it has completed, proceed 
to click the button “Download ELEMENTS.COMET”.  Finally, when that has completed, click “Verify 
Database”.  There should be over 1 million asteroids and over 900 comets listed. 
 
There is also a path to a file labeled “MPCORB.CUSTOM”.  This ‘custom’ variant of MPCORB allows you 
to put in the orbital elements of objects that are not listed in the official MPCORB file, but will still be 
recognized as a valid MPCORB file for the purpose of object matching.  You can add custom elements 
either by directly modifying this file, or by going to Tools->Existing Observations and choosing Orbital 
Elements->Add to MPCORB.CUSTOM.  Note that this requires Find_Orb to be configured. 
Set the other settings as shown in Figure 7. 
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Configure the Star Catalog 
 
Proceed to Settings->Star Catalog to configure the appropriate settings.  For most photometry work, it is 
recommended to use the new ATLAS catalog (also known as ATLAS-REFCAT2).  The Downloads page on 
the Tycho website includes three different links to this catalog, allowing you to choose the desired 
coverage from magnitude 16 up to magnitude 20.  Refer to the notes on the ATLAS tab for details on 
how to acknowledge use of this star catalog in a published paper. 
 

 
Figure 8 - Configuring the Star Catalog 

 
To configure an offline star catalog (such as ATLAS), navigate to the relevant tab and specify the full path 
to the folder that contains the “de_*” folders (“z*” in the case of UCAC4).  Then, navigate back to the 
“Options” tab and select the desired catalog from the dropdown menu next to “Catalog”. 
 

Primary Use Case Recommended Star Catalog MagBand Filter 

Astrometry of asteroids Gaia EDR3 (G) Gaia None 

Photometry of asteroids ATLAS (r) Sloan R None 

Photometry of variable stars ATLAS if wanting ensemble. 
AAVSO otherwise. 

Should match 
the filter 

B, V, R, I 

 
For asteroids, it is recommended not to use a filter, so that you can capture as much light as possible on 
these faint targets.  For photometry of variable stars, the ATLAS catalog can be used if wanting an 
ensemble of comparison stars.  However, it is also possible to use AAVSO comparison stars regardless of 
the chosen catalog.  This is achieved by overriding the catalog from within the “Image Viewer” 
photometry menu, “Download AAVSO Chart”.  More details are provided in the photometry section. 
 
To summarize: If in doubt, use the ATLAS catalog.  It can be overridden by AAVSO comp stars later on. 
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Configure the Alignment Software 
 
Navigate to Action->Align Images to 
specify the settings for the alignment 
routine.  You can choose to use an 
external program such as RegiStar or 
PixInsight, or you can use the internal 
alignment routine.  If using an 
external program, navigate to its tab 
and specify the path to its 
executable.  If using the internal 
routine, navigate to the “Internal” 
tab and select the desired options.  
Click “Save Settings” to continue. 
 
 

Configure Observatory Codes 
 
If you have not already done so, you may want to configure the Observatory Code file, “ObsCodes.html”.  
This file allows Tycho and Find_Orb to recognize the different observatory codes that have been issued 
by the Minor Planet Center. 
 
You may update the file by going to Settings->ObsCodes and clicking the button labeled “Download 
ObsCodes.html”.  Then, if you have configured Find_Orb, you can also keep it updated by clicking the 
button labeled “Copy to FindOrb Directory”.  The button labeled “Verify Path” allows you to validate 
that the file was downloaded correctly.  As of January 2, 2021, there were 2248 observatory codes 
specified in the file. 
 

 
Figure 10 - Loading Observatory Codes 

  

Figure 9 - Alignment Settings 
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Configure the Plate Solver 
 
Plate solving is necessary an order to determine image characteristics such as plate scale, orientation, 
and sky coordinates.  Since plate solving is performed after alignment, it is only necessary to plate solve 
the first image in the sequence. 
 
Tycho considers an image to be “plate solved” when two conditions are satisfied.  The first is that the 
image must contain World Coordinate System (WCS) entries inside its FITS header.  The second 
condition is that the entries must correspond to a 3rd-order SIP polynomial. 
 
There are three ways to plate solve an image.  The first of which is to use the Tycho online service which 
invokes the solve-field software developed by Dustin Lang et al.  This is the easiest and preferred 
technique for most users, and is also very fast because it does not upload the image data – only the 
extracted sources.  The second option is to download the solve-field software onto your own machine, 
along with the necessary index files.  This option may be useful for those who do not have a reliable 
Internet connection.  Finally, the third option is to use the astrometry.net online service, being sure to 
specify “tweak_order=3” for the 3rd-order polynomial.  This option is the slowest as it requires uploading 
the full image data. 
 

Plate Solve Option 1: Using the Tycho Online Service 
 

 
Figure 11 - Settings for Tycho Online Solver 
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As mentioned, the Tycho online service is recommended for most users as it is quick, easy, and reliable.  
Navigate to Action->Plate Solve Images and configure the solver as shown in Figure 11.  Then click “Save 
Settings” to save the settings for future use.  When you are ready to plate solve, click the “Start” button. 
 
Note: 
The default Downsample factor is 2, and usually works.  However, if you have large images (3000x3000 
or larger) then it may be useful to try a Downsample factor of 4.  Conversely, if you have small images 
(700x700 or smaller) then it may be useful to try a Downsample factor of 1. 
 
Also new in v9.2 is the ability to select “Standard” or “Extended” mode for star extraction.  This applies 
only to the online solver.  If you have smaller images, or are experiencing issues with getting a solution 
returned, you may wish to try the “Extended” extraction mode. 
 

Plate Solve Option 2: Using the Offline Plate Solver 
 
The offline solver may be desired by users who do not have a reliable Internet connection.  For this 
option, the first step is to download the offline solver, a mirror of which is available from the Tycho 
website via the Download page from: https://www.tycho-tracker.com/download  
 
Click on the “[ZIP]” link next to the offline solver entry, and you will start downloading the software for 
the offline solver.  Once downloaded, extract the archive and run the setup executable.  When the setup 
has completed, be sure to check the box “Run the Astrometric Index Downloader”. 
 

 
Figure 12 - Installing the Offline Plate Solver 

 
It is not necessary to “Start ansvr” at this time, so you can uncheck that box. 
 
The Index Downloader is important because it will automatically download the index files required for 
your field of view.  Index files are used by the solver to perform the plate solve routine, and without 
them the solver will not function. 
 

https://www.tycho-tracker.com/download
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Figure 13 - Index Manager 

 
Click “Start” once you are satisfied with the settings for “Narrowest field” and “Widest field”.  The Index 
Downloader will then proceed to download the relevant index files.  When it is finished, you can close 
the window. 
 
It is also recommended to install the 4100 series of index files.  They are available here: 

• http://broiler.astrometry.net/~dstn/4100/ 

• There are 13 .fits files totaling 340MB in size 

• After downloading the files, place them into your index file directory (this will be similar to 
C:\Users\<user>\AppData\Local\cygwin_ansvr\usr\share\astrometry\data) 

 
Once the plate solver has been installed, along with the index files, launch Tycho and choose “Action-
>Plate Solve Images”.  Provide the path to the cygwin_ansvr directory, this is usually going to reside 

in your local AppData directory. 
 
If you know the plate scale of your imaging chip, you can provide a lower- and upper-bound on the pixel 
scale.  For example, if your plate scale is 1.6, you may specify 1.4 as the lower bound and 1.8 as the 
upper bound.  If you are unsure, it is perfectly fine to specify a wider range such as 0.5 to 3.0. 
 
“Downsample=2” will usually produce a good result.  However, if you have a wide field or a large image 
then “Downsample=4” is probably better, and a lot faster.  If you are experiencing plate solve failures, 
you might experiment with different values to see what works best for your images. 
 
The option “Automatically perform second attempt with different source image” allows the plate solver 
to automatically perform a second attempt if the first attempt fails.  It will also select the middle image 
in the sequence as the source image and, upon successful solve, copy its WCS information over to the 
first image in the sequence.  This can be a useful fallback if the first image fails to solve. 
 
The option “Narrow search to RA/Dec in FITS header” is useful to prevent false matches from occurring.  
It is very rare for the plate solver to produce a false match, but it has happened on at least one occasion.  
Therefore, this option can be enabled to instruct the plate solver to search within a given radius of the 

http://broiler.astrometry.net/~dstn/4100/
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RA/Dec specified within the FITS header of the first image.  If the RA/Dec is not found in the FITS header, 
the plate solver will revert to conducting a “blind search”, which is the same behavior as if the option 
were disabled.  The default search radius is 15.00 degrees, meaning that the RA/Dec in the FITS header 
can be off by that amount from the actual RA/Dec.  Evaluation of numerous datasets has shown that 
while most FITS headers will have the RA/Dec correct to within 5 arcmin, some can be off by several 
degrees.  Thus, to ensure that the plate solver is not overly constrained, it is advisable to have a 
sufficient radius, which will still reduce the probability of an incorrect solution being returned. 

 
Plate Solve Option 3: Using the Astrometry.net Service 
 
Here are the steps to solve an image using the astrometry.net online service.  Note again that you need 
only solve the first image in the dataset. 
 
First, navigate to http://nova.astrometry.net and click on the “Upload” menu item. 
 
Before uploading the file, click on the “Advanced Settings” text and scroll down to the following settings. 
 

 
Figure 14 - Advanced Settings for Online Plate Solver 

 
“Tweak” should be set to 3 in order to satisfy the 3rd-order polynomial requirement. 
“CRPIX center” should ideally be checked, but it is not usually problematic if left unchecked. 
“Downsample” is by default 2, but you may find that 4 works better for some images. 
 
Once these Advanced Settings have been specified, proceed to upload the image and wait for the 
service to return with a result.  When the service has finished, you can download the plate solved image 
by clicking on the “new-image.fits” link, as shown in Figure 15. 
 

http://nova.astrometry.net/
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Figure 15 - Retrieving the Plate Solved Image 

 
Once downloaded, you can replace the unsolved first image with “new-image.fits”, which will take the 
place of the first image in the image sequence.  As you can see, the astrometry.net service is a bit more 
tedious than using the integrated solvers, but is one more option available should it be desired. 
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Acquiring an Observatory Code 
 
The Minor Planet Center (MPC) is the official authority behind the process of requesting and acquiring 
an observatory code.  For the purpose of providing a tutorial, some steps of the process are outlined. 
 
This page from the MPC website provides some details on acquiring an observatory code: 
https://www.minorplanetcenter.net/iau/info/Astrometry.html 
 
From section 16, “How do I begin?”: 
 

If your site does not have an observatory code, one will be assigned upon acceptance of your initial 
submission. Your initial submission should contain at least six numbered minor planets each on pairs 
of nearby nights as well as one numbered Near-Earth object observed on two distinct nights. If 
weather interferes, the two nights can be some weeks apart. Report at least three observations of 
each object from each night: do not report single positions per night. Batches that contain single 
positions will be returned in their entirety to the submitter. We will check these positions and advise 
you on their quality. As a general rule we advise you NOT to observe very low-numbered objects--e.g., 
(1), (2), (51) and very bright objects. In your initial batch please submit astrometry of objects fainter 
than 14th magnitude. In addition, you should try and observe objects of various brightness. 

 
From someone who recently acquired an MPC code: 
 

Your first submission of measurements should contain XXX for observatory code for the MPC to 
recognize it as a code request/application.  Immediately after you make your first XXX submission, you 
will get an email directing you to enter some information for your code application.  That submission 
and all other submissions you make until you get a code should only contain two-night measurements 
on asteroids in the range identifier of 800-40,000. 

 
From another user who also recently acquired an MPC code: 
 

After my initial submission was accepted (with observations of two different asteroids) I was asked to 
submit more observations of other asteroids.  The email also had a link to fill in coordinates of the 
observatory and some other details.  For the second set of observations, I used code XXX and sent 
observations of 4 asteroids.  Within a few days, I sent observations of one more asteroid with code 
XXX.  I waited for two weeks from the time I submitted my second set to get my observatory code. 

 
The Tycho software makes it easy to generate a report in the format required by the MPC.  This is 
explained later as you work through the example datasets.  It is also recommended to use the MPC1992 
format for the initial submissions, and later the ADES format if desired.  This is because ADES does not 
yet support the “XXX” (new observatory) code. 
 
Until you have a code, you want to make sure that the option “Applying for a new MPC code” is selected 
as the “Observatory Status” (refer to the section “Configure Observatory Information”). 

 
Note:  The example dataset provided in this tutorial was taken from an observatory that already has a 
code (Q62).  When applying for a new code, you must use images taken from your own observatory. 
  

https://www.minorplanetcenter.net/iau/info/Astrometry.html
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Example #1: Measuring a Known Asteroid (using only 4 images) 
 
The purpose of this first example is to demonstrate how to use Tycho with a minimum set of images for 
basic measurement.  Later examples will show how to use the synthetic tracker, which requires at least 
11 images, enabling the detection of very faint asteroids. 
 

Step 1: Load the Images 
 
Launch Tycho.  From the “Image Manager”, choose List->Add Images, and load the images contained in 
the example dataset labeled “ds1”.  There should be exactly four images. 
 

 
Figure 16 - Image Manager with Four Images Loaded 

 
Step 2: View the Images 
 
It is always good practice to verify the quality of the images.  To do this, navigate to Action->View 
Images from the main menu.  This will open the “Image Viewer” window.  Now, if you go back to the 
“Image Manager” window, you can click on the different images and see them displayed in the “Image 
Viewer” accordingly.  You will note that they are not yet aligned as there is some noticeable shift from 
one from image to the next.  But the quality of the images is good, with stars having acceptable focus. 

 
Step 3: Calibrate the Images 
 
Now that you have visually inspected the images, it is time to prepare them for processing.  The first 
step in this procedure is calibration.  Navigate to Action->Calibrate Images from the main menu and you 
will see a new window appear for calibration settings. 
 
Because these images have already been dark subtracted and flat fielded, it is not necessary to perform 
those steps here.  However, when you are calibrating your own images, be sure to apply the appropriate 
dark frame and flat frame sources.  For flat frame calibration, “pseudo flat” works quite well, especially 
if you do not have a flat frame available.  But for this dataset, the only calibration required is to 
normalize the images.  This is important when using the synthetic tracker (as shown in later examples).  
So, choose the option “Normalize Images”.  However, when doing sensitive photometry, it is better not 
to use normalization for best results. 
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Figure 17 - Calibration Settings 

 
Next, click “OK” to proceed with calibration.  The resulting images will be saved in a new folder labeled 
“ds1_c”.  Navigate to that directory and load the now-calibrated images. 

 
Step 4: Align the Images 
 
The next step is to align the images.  Proceed to Action->Align Images and choose the desired alignment 
option.  If you have not already done so, navigate to the relevant tab and configure the settings.  Click 
“OK” to proceed.  As before, the images will be saved to a new directory, this time labeled “ds1_c_a”. 
 

 
Figure 18 - Align Images 
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Step 5: Plate Solve the Images 
 
Navigate to the newly-aligned images, contained in directory “ds1_c_a”.  Load them as before.  Now go 
to Action->Plate Solve Images. 
 

 
Figure 19 - Plate Solve Images 

 
The images have a known pixel scale of around 1.65”/pixel.  However, you can choose a wide lower- and 
upper-bound for the pixel scale, as shown in Figure 19.  For more details, refer to the section labeled 
“Configure the Plate Solver”.  Proceed to plate solve the images by clicking the “Start” button. 
 
When the solver has finished, the images will remain loaded in the “Image Manager” – no new output 
directory is generated at this step.  It is good practice to validate the plate solve by going to Action-
>View Images, and checking that the catalog stars (blue boxes) are overlaid on top of the actual stars.  
To do this, choose File->Load Star Catalog from the “Image Viewer”. 
 
If you do not see any stars, make sure Display->Catalog Stars is checked, and that you have configured 
the Star Catalog settings.  If you have not configured the star catalog, now is a good time to do so.  Refer 
to the section labeled “Configure the Star Catalog” for more details. 

 
TIP: Using “Express Mode” 
 
As you have observed, it can be rather tedious to perform each of the above steps manually.  For this 
reason, there is a feature called “Express Mode”, which streamlines the process.  If you would like to try 
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“Express Mode”, load the original (uncalibrated, unaligned) images into the “Image Manager”, and then 
navigate to Action->Express Mode from the main menu. 
 

 
Figure 20 - Express Mode 

 
As you can see, “Express Mode” offers the ability to carry out each step in an automated and 
streamlined fashion.  Once you have the correct settings for each step, click the “Start” button and the 
program will automatically perform each step.  When it is finished, the results are stored in a single 
output directory with the appropriate labeling. 
 

Step 6: Verify Observatory Settings 
 
Now that the images have been calibrated, aligned, and plate solved, it is time to start generating some 
measurements (also known as “observations”).  Load up the processed images, and then navigate to 
Action->View Images from the main menu. 
 
Important: Before you proceed, you will need to change your observatory settings to match those of the 
observatory that acquired these images.  In this example, the observatory that acquired these images 
has Minor Planet Center (MPC) code “Q62”, located in Siding Spring, Australia.  To make this change, 
navigate to Settings->Observatory from the main menu and choose Action->Add Observatory from the 
window that appears.  Give the observatory a label such as “Siding Spring” and then choose “Already 
have an MPC code” for the observatory status.  Specify “Q62” for the MPC code, and click the button 
“Apply location from MPC code” to automatically populate the location details.  For the telescope 
section, you can populate the details as shown in Figure 21.  Then click the “Next” button and make sure 
to use the same settings as shown in Figure 22.  Then, click “Finished”. 
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Figure 21 - Adding Observatory, Page 1/2 

 

 
Figure 22 - Adding Observatory, Page 2/2 

 
Now that “Siding Spring” has been added as an observatory, proceed to make it the “Active 
Observatory” by right-clicking on it in the list and choosing “Make Active”. 
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Step 7: Load Known Objects 
 
Back at the “Image Viewer”, you can now proceed to have Tycho show known objects in the field by 
going to File->Load Known Objects from the “Image Viewer” menu.  This feature depends on having the 
Find_Orb software installed and configured in order to precisely compute the positions of asteroids, so if 
you have not yet configured the settings for Find_Orb, it is recommended to do so now.  Refer to the 
section labeled “Configure the Find_Orb Software” for more details. 
 

 
Figure 23 - Known Objects 

 
At this point, a window should appear with a list of all known objects for this field.  As you click on each 
item in the list, the “Image Viewer” will automatically update to the location of the object.  If the object 
does not appear centered in the crosshairs, then you may need to verify either the observatory settings 
as described earlier (this dataset was acquired with MPC code Q62), or the “Known Objects” settings 
(Settings->Known Objects from the main menu).  In rare situations, some cameras may specify a DATE-
OBS that is not in UTC time; in these scenarios, you can specify the time offset to correct for this. 
 

Step 8: Create and Verify Track 
 
As an example, right-click on object with “Number” (permanent ID) of “(38826)”, also known as “2000 
RZ92” (its provisional ID).  When you have right-clicked the object, choose “Add to Track Navigator”.  
You can also do this with multiple objects at a time, but for now focus on just this object. 
 
With the object added to the “Track Navigator”, you can either double-click it, or right-click and choose 
“Verify Track”.  An animation of the object should now be shown in the “Image Viewer”, showing the 
movement of the asteroid. 
 
The “Verify Track” window will limit to 3 observations by default.  Generally, even if you had 60 images 
loaded, it is good practice to limit to 3 observations.  The reason for this is that Tycho can then use 20 
images for each observation, resulting in a much higher signal-to-noise ratio (SNR) for each observation.  
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But if you want more observations, check the box “Advanced mode” and the drop-down list will allow 
you to have as many observations as there are images.  In this example, proceed to generate three 
observations as shown in Figure 24. 
 

 
Figure 24 - Verify Track 

 

Step 9: Create Measurements 
 
Click the “Add Observations” button to continue.  The “Object Designation” window will now appear, 
prompting for the designation of the object.  Since this is a known object, the fields should already be 
populated. 
 

 
Figure 25 - Object Designation 

 
Click “OK” to proceed.  The measurements (observations) have now been generated for this object. 
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At this point, you will want to verify that the observations were correctly generated by clicking on each 
measurement in the “Observations – All Targets” window. 
 

 
Figure 26 - Observations -- All Targets 

 
As you click on each observation, the “Image Viewer” window is updated to show the centroid of the 
observation.  You will note that the first observation uses a stack of the last two images. 
 

 
Figure 27 - Visual Inspection of Observations 
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Step 10: Validating the Measurements 
 
You can validate the measurements by selecting them, then right-click and choose “View with Existing 
Observations” from the popup menu that appears.  It may take a moment, as the observations from 
other observatories are downloaded.  When it is finished, a new window appears showing all of the 
observations for this object, with the ones that you just created at the very bottom. 
 
As measurements of this object were already submitted by Q62, you will want to remove those 
observations from the list before doing the comparison.  You will note the observations have a date of 
2018 09 10, so scroll up in the list to around that timeframe and remove the observations that have Q62 
in the far-right column.  There should be about six observations to be removed. 
 
When ready, click on “View in Find_Orb” (the button in the lower-right corner of the window), and the 
Find_Orb software will show the residuals for these three measurements that you just generated. 
 

 
Figure 28 - FindOrb Results 
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As you can see, the measurements are quite good, with “0.31” being the highest residual.  Generally, 
any measurement with a residual below 1.50 is acceptable, but it is preferred to have residuals below 
1.00.  Several factors can influence the quality of measurements, including: 
 

1) Accuracy of time source (especially important with fast-movers) 
2) Star catalog 
3) Quality of images 

 

Step 11: Generating the Measurement Report 
 
Now that you have validated the measurements, you can proceed to generate a report that could be 
used for submission.  Note that these measurements should not be submitted as they are only for 
example purposes. 
 
To generate the report, navigate back to the “Observations – All Targets” window.  Then choose Report-
>Generate MPC1992 Report if you wish to generate an MPC1992 report.  Otherwise, if you wish to 
generate an “ADES” report, choose Report->Generate ADES Report. 
 

 
Figure 30 - Generating the Measurement Report 

As you can see, the three observations are shown in an MPC1992 report.  The first observation, being a 
stack of two images, has the “K” attribute next to the date. 

COD Q62 

CON D. Parrott 

OBS D. Parrott 

MEA D. Parrott 

TEL 500mm Reflector + CCD 

NUM 3 

ACK MPCReport file updated 2021.01.03 18:26:22 

NET Gaia DR2 

38826        KC2018 09 10.58639 22 56 39.58 -07 50 40.8          17.3 G      Q62 

38826         C2018 09 10.61431 22 56 37.71 -07 50 43.4          17.4 G      Q62 

38826         C2018 09 10.63394 22 56 36.41 -07 50 45.3          17.4 G      Q62 

----- end ----- 

 
Figure 29 - MPC1992 Report 
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Example #2: Measuring an “Unknown” Asteroid (using only 4 images) 
 
This example expands upon the first example in that it assumes you now know how to calibrate, align, 
and plate solve images.  If not, please consult the first example for details on how to carry out those 
steps. 
 
This example will show how to generate measurements of an “unknown” asteroid.  In fact, the asteroid 
is already known, but for this example we will pretend otherwise.  The purpose of this example is to 
show how to measure an asteroid without relying on the “Known Object” functionality. 
 

Step 1: Load and Process Images 
 
As before, proceed to calibrate, align, and plate solve the images.  The images are the same as that in 
the first example, using dataset “ds1”.  Once you have finished processing the images, load them up and 
launch the “Image Viewer” by going to Action->View Images from the main menu. 
 

Step 2: Blink Images 
 

 
Figure 31 - Input RA/Dec Coordinates 

 
From the “Image Viewer” menu, choose Location->Center on RA/Dec.  A new window will appear, 
prompting for RA/Dec coordinates.  You may either input the RA/Dec in the sexagesimal format, or in 
decimal format.  For this object, its coordinates on the first image are as follows: 
 
RA =  22 56 39.95 

DE = -07 50 39.50 (note the “-07” is negative 07 degrees). 
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Click the “OK” button within the “Coordinates (Sexagesimal format)” section and the “Image Viewer” 
will be updated to display the image at those coordinates.  You will notice that this looks similar to the 
asteroid measured in the previous example, and it is in fact the same one.  But this time we will be 
measuring it in a different fashion. 
 

 
Figure 32 - Asteroid (38826) 

 
Again, pretending that this is an “unknown” asteroid, blink through the images to reveal the moving 
object.  You can either scroll through the images in the “Image Manager”, or you can have the images 
blink in an automated fashion.  If you wish to have them blink automatically, you can right-click inside 
the “Image Viewer” and choose “Create Track – From Current Position”.  In this particular scenario, it is 
not necessary to worry about the “current position”, right-clicking anywhere inside the image should be 
fine.  Since no motion has been defined, the new track will have a motion of zero, which allows the 
images to be blinked normally.  Once the track has been added, double-click it to bring up the “Verify 
Track” window.  Since you are just using this to blink images, you do not need to worry about creating 
observations yet.  Also, in the “Animation” section, uncheck the box “Follow Target” and choose “4 
stacks” so that each image is included separately in the blink animation.  As you blink the images, you 
will see the motion of the object.  To stop the blinking, either click the “Pause” button or click on an 
image in the “Image Manager”.  New in v8: You can now animate from the Image Manager by choosing 
“Animate->250 ms” (or another interval).  To stop the animation, navigate to “Animate->None”. 
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Step 3: Create Markers 
 
Proceed to click on the first image in the “Image Manager”, then double-click on the object in the 
“Image Viewer” so that it is properly centered in the crosshairs.  Now, right-click, and choose “Create 
Marker 1”.  Then, click on the last image in the “Image Manager”, and double-click on the object once 
more.  This time, right-click and choose “Create Marker 2”. 
 

 
Figure 33 - Markers Window 

 
Step 4: Create a Track 
 
Having defined two markers to indicate the motion of the object, you can now create a track using these 
markers.  This track will use the markers to compute the speed and position angle of the object.  To 
create this track, right-click in the “Image Viewer” and choose “Create Track – From Markers”.  You now 
have a second track, this time with speed and position angle (PA) of the object populated. 
 
As before, you can double-click on the track and the “Verify Track” window will appear.  But this time, 
the blinking animation will follow the actual object as it has now been programmed with its motion.  So, 
if you check the box “Follow Target”, the object should remain centered within the crosshairs.  At this 
point, you can proceed to create observations of the object, in a similar fashion to how you created 
observations in the first example. 
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Figure 34 - Manually Created Tracks 

 
Example #3: Creating Measurements Manually 
 

Step 1: Center the Asteroid 
 
With the images from the second example still open, go back to the “Image Manager” and click on the 
first image.  Now, with the first image shown, go to the “Image Viewer” and double-click on the asteroid 
to center it. 
 

Step 2: Create a Measurement 
 
Now choose Create->Observation from the “Image Viewer” menu, or right-click inside the “Image 
Viewer” and choose “Create Observation” from the popup menu that appears.  In either case, a new 
observation will be created and shown in a new window, “Observations – Single Target”. 
 
This approach allows you to manually create measurements without relying on the “Track Navigator”.  It 
also gives you more flexibility as you can choose what layer is used to generate the measurement: 
“median”, “avg” (mean), or “Abv” (detection layer).  When you create a stack, these layers will all be 
different, with the “Abv” layer performing best at eliminating star interference and the “Avg” layer 
showing star trails.  By default, the “Track Navigator” uses the “Abv” layer as it is usually best for 
automated generation of measurements and works well in crowded star fields; however, sometimes the 
“Avg” layer might be better, especially when the object has little movement. 
 
Since you have not stacked any images, the layers will appear identical, as a single exposure is shown. 
 

Step 3: Create a Stack (all images) 
 
You have just now manually created a measurement using a single exposure.  Now let’s try creating a 
measurement using several exposures.  Right-click in the “Image Viewer” and choose “Create Stack - 
Custom” from the popup menu that appears.  This allows you to create a stack with a custom motion, 
either in terms of “Speed/PA” or in terms of “X/Y” motion.  For this example, we will specify the motion 
of the asteroid with speed=0.7”/min and PA=265 degrees. 
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Figure 35 - Create Stack (Custom) 

 
Now click the button “Create Stack (Speed/PA)”.  You will note that the “Image Viewer” will be updated 
and will display a stack using median combine, average (mean) combine, or “Abv” combine.  If you want 
to change the stack type (layer), then you can change the appropriate setting and click on “Create Stack 
(Speed/PA)” again.  An example of the “Abv” layer is shown in Figure 36. 
 

 
Figure 36 - "Abv" Stack 

 
If the object is not centered in the crosshairs, double-click on it to center it.  Then, right-click and choose 
“Create Observation”.  You will now have a second observation listed, this time using all four exposures 
(ImgStart=1, ImgStop=4).  Again, this is just an example; in practice, you would never create a 
measurement that reuses exposures from another measurement – ALWAYS use distinct and separate 
exposures for each measurement.  The measurements may be generated from multiple exposures, but 
the exposures used by each measurement should be different from those used in other measurements. 
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Step 4: Create a Stack (subset of images) 
 
As the previous step showed, if you create a stack with no images selected, it will create a stack using all 
of the images.  This can be useful in certain scenarios when you want to stack all of the images to get the 
maximum SNR.  But in this case, it also means that when you created the observation, you wound up 
with a measurement that uses all of the exposures – which you might not want.  So, you may be 
wondering how to create a stack using only a subset of the images. 
 
To do this, go back to the “Image Manager”, and select the last three images (the first image should not 
be highlighted, while the last three should be highlighted). 
 

 
Figure 37 - Selecting the Last 3 Images 

 
Then, go back to the “Create Stack – Custom” window (simply labeled “Stack”), and click on the button 
“Create Stack (Speed/PA)”.  This time, when it creates the stack, it will do so using only the last three 
images.  As you can see in Figure 38, when the stack is created with “Avg” layer (not Abv), it is evident 
that three images were stacked because each star leaves behind three “footprints” in the image. 
 

 
Figure 38 - Stack with 3 Images 
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Now that you have generated this stack of three images, you can create another observation.  Double-
click on the asteroid to center it, and then right-click and choose “Create Observation”.  This time, you 
will note that “ImgStart=2” and “ImgStop=4”, meaning that images 2, 3, and 4 were used to generate 
this measurement.  Proceed to delete the earlier measurement that used all of the images, which should 
leave you with two measurements total. 
 

 
Figure 39 - Observations -- Single Target 

 
Tip: In a later example, I will also show how to create these “sub-stacks” using the “Track – Positions” 
window, which is far more convenient than manually creating each stack. 
 

Step 5: Add to Target List 
 
At this point, you have created measurements of some object.  It could be an asteroid, a comet, a 
satellite, even just a star.  The next step is to add these measurements of that object to the “Target List”, 
which allows them to be treated alongside measurements of other objects.  So, proceed to click the 
“Add to Target List…” button.  You will get a new window asking for the designation of the object.  The 
permanent ID (permID) is 38826.  Since it is a numbered object, there is no need to specify the 
provisional ID.  Click “OK” to continue. 
 
You will note the familiar window shown in the first example, “Observations – All Targets”.  Here again, 
you could validate the measurements and generate a report.  You could also click on each observation 
to see the green centroid indicating the exact center of the object.  Generally speaking, it is not 
worthwhile to publish just two measurements of an object (3 measurements are preferred), but the 
purpose of this example was to show how to generate measurements in a manual fashion. 
 

Step 6: Manually Adjusting the Centroid 
 
Before going on to the next example, let’s try one more task.  Here, we will pretend that one of the 
measurements had a poor centroid and requires manual correction.  This is usually rare to occur, but if it 
happens, it is worthwhile to know how to fix it manually. 
 
On the “Observations – All Targets” window, click on the second observation of the object.  You will see 
the object centered with both the red crosshairs and the green centroid indicator.  Again, let’s pretend 
that the green centroid needs adjustment, so right-click on the observation and choose “Modify 
Observation”.  This will bring up a new window as shown in Figure 41. 
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Figure 40 - Green Centroid Indicator 

 

 
Figure 41 - Modify Observation 

 
From the “Modify Observation” window, there are two ways to adjust the centroid.  One is to move the 
centroid with fine adjustment (1/10th of a pixel).  To do this, check the box “Move centroid with arrow 
buttons”.  Then click on the arrow buttons in the “Image Viewer” to move the centroid.  When finished, 
click “Apply centroid specified by green crosshairs”.  You should see the “RA” and “DEC” of the 
observation be updated in the “Observations – All Targets” window when the button is clicked. 
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The other method to adjust the centroid is by specifying an initial pixel location from which Tycho will 
then compute a more accurate centroid.  In other words, if the observation is “way off”, the pixel 
location can be used to get it back in the “ballpark” and then Tycho can re-compute the correct centroid.  
To use this method, uncheck the box “Move centroid with arrow buttons”, and proceed to pan the 
image to where the object is located (even just double-clicking on the object).  Then click the button 
“Re-calculate centroid using current pixel location”.  As with the other method, the “RA” and “DEC” of 
the observation should be updated in the “Observations – All Targets” window. 
 
You can also use the “Modify Observation” window to change which layer is used for the observation.  
So, if you wanted to use the “Median” layer rather than “Avg” layer, you could open the “Modify 
Observation” window, double-click the object, and click “Re-calculate centroid using current pixel 
location”.  The centroid (as well as magnitude information) will then be recomputed using the specified 
layer. 
 
Note: If you click on a different observation and the green centroid indicator does not follow it, that is 
likely because the “Modify Observation” window was kept open.  Close the “Modify Observation” 
window when finished with it.  It will also close by itself whenever you actually modify the observation, 
or whenever you click “Cancel”. 
 

Example #4: Measuring a Faint NEO (without synthetic tracker)  
 
This example expands upon the first example in that it assumes you now know how to calibrate, align, 
and plate solve images.  If not, please consult the first example for details on how to carry out those 
steps. 
 
This example will show how to generate measurements of a faint NEO that is not detectable on 
individual frames.  As such, unlike the previous examples that had a bright asteroid, this example makes 
use of many exposures in order to produce a sufficient signal-to-noise ratio (SNR). 
 

Step 1: Load and Process Images 
 
Load the dataset for this example, “ds2”, and proceed to perform calibration, alignment, and plate 
solving.  There should be 39 images in this dataset. 
 

Step 2: Download Observations for the NEO 
 
Navigate to Tools->Download Observations from the main menu.  At the prompt, type in “2018 RB” for 
the object name, and choose the option “From obs database (confirmed object)”.  Then click “OK” to 
proceed.  After a moment, a new window will appear, “Text Form – Observations”.  This window should 
be populated with the observations for the NEO. 
 

Step 3: View the Observations in Find_Orb 
 
Click the button in the lower-right corner, labeled “View in FindOrb”.  The Find_Orb program will launch 
and compute the orbit for this object using the observations from the text form.  Continue to leave 
Find_Orb running in the background for the next step. 
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Figure 42 - Download Observations 

 

 
Figure 43 - Text Form -- Observations 

 
Step 4: Attach Ephemeris to the Dataset 
 
With Find_Orb still in the background, navigate back to the “Image Manager” and choose Ephemeris-
>Attach to Dataset from the “Image Manager” menu.  From the window that appears, double-click on 
the appropriate instance of Find_Orb (if you have multiple instances running, choose the one with “2018 
RB”).  You will note that the “EPH_” columns in the “Image Manager” are now populated with 
information about the object.  If you scroll to the far-right, you can see the “EPH_IN_FOV” column which 
indicates whether or not the object is expected to be in the field of view for each image.  This can be 
helpful as you typically want to exclude images where it is not in the field of view.  For this dataset, the 
object should be in the field of view of each image, so the column should indicate “Yes” for every image. 
 

Step 5: Create Stack (using ephemeris) 
 
Now that the ephemeris information has been attached to the dataset, proceed to view the images by 
going to Action->View Images from the main menu.  Then, right-click inside the “Image Viewer” and 
choose “Create Stack – Ephemeris” from the popup menu appears.  Alternatively, you can also choose 
the option by going to Create->Stack – Ephemeris from the “Image Viewer” menu.  At this point, you will 
note that the “Image Viewer” has been updated with a display of a stacked image according to the 
computed motion of the object. 
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Figure 44 - Result of "Create Stack - Ephemeris" 

 
In Figure 44, you can see the result of creating the stack.  If your results look different, you may be using 
a different layer such as “Median” or “Abv”.  For this example, choose “Avg”, and then recreate the 
stack to force an update of the display.  Also, you can adjust the contrast to make the object stand out 
better.  I chose (164) for the contrast slider. 
 

Step 6: Create a Track 
 
Double-click the object to ensure that it is centered in the crosshairs.  Then right-click and choose 
“Create Track – Current Position” from the popup menu that appears.  This will add a new track to the 
“Track Navigator”. 
 

Step 7: Create Measurements 
 
Double-click on the track and you can see the “Verify Track” window appear.  Click the “Add 
Observations” button.  Another window appears, “Object Designation”, prompting for the designation 
of the object.  Specify “2018 RB” (without the quotes) for the “Provisional ID (provID)” field.  The object 
does not have a permanent designation, so leave (permID) blank.  Click “OK” to continue. 
 
As before, you can perform a visual inspection of each observation by clicking on them in the 
“Observations – All Targets” window.  On rare occasions you might also want to manually adjust the 
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centroid; if so, please refer to the section labeled “Step 6: Manually Adjusting the Centroid” in the 
previous example.  For this example, there should be no need to modify the centroid. 
 

Step 8: Validate the Measurements 
 
As described in the first example, you can validate the measurements by right-clicking on them and 
choosing “View with Existing Observations”.  This will bring up the “Text Form – Observations” window, 
with the newly-created measurements at the very bottom.  Again, the observatory that acquired these 
images is “Siding Spring” in Australia, with MPC code “Q62”.  So, if you are seeing a different MPC code 
shown in the far-right of the observation text, you will need to make “Siding Spring” the active 
observatory.  Refer to the first example for details on how to do this. 
 
Because Q62 already submitted observations of this object, you will want to remove those observations 
from the list before comparing your newly-created observations with those from other observatories.  
Scroll up the list until you reach 2018 09 10 and locate the observations by Q62.  There should be 
around six observations; delete them and leave the others. 
 
Now click the button “View in Find_Orb” and you should see the residuals (errors) for the observations 
you just created.  From this instance of Find_Orb, it appears that the highest residual is “0.21”, which is 
quite good.  Again, any measurement with a residual under 1.50 is “acceptable”, but it is preferred to be 
under 1.00 when possible. 
 

 
Figure 45 - Validating the Measurements 
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Step 9: Generate Report 
 
As described in the first example, you can now proceed to create either an MPC1992 report or an 
“ADES” report by going to Report->Generate MPC1992 Report or Report->Generate ADES Report from 
the “Observations – All Targets” window. 
 
As before, do not submit these observations, as they are only for example purposes. 
 

Step 10: Using “Track – Positions” to Generate Sub-stacks 
 
While the images are still loaded, try experimenting with the “Track – Positions” window.  This window 
should still be open from having created the track earlier.  If not, you can go to Window – Track – 
Positions from the main menu to bring it to the front.  If you do not see the window in the list of 
available windows, then you should try clicking on the track in the “Track Navigator”.  Or, worst case 
scenario, if the “Track Navigator” window is no longer open, proceed to re-create the track as described 
in the previous step “Step 6: Create a Track”. 
 
Now that you have the “Track – Positions” window in view, click on the first entry in the list.  This will 
update the “Image Viewer” to center on the object in the first image.  You may want to reset contrast 
back to “(0)” when examining individual images.  With the first entry still highlighted in the “Track – 
Positions” window, use the “Down” arrow key on the keyboard to rapidly move to the other entries.  
You should now see the object appear to move in the “Image Viewer” as it follows the object on each 
image.  From this, you can see that the object is indeed quite faint on each individual exposure. 
 
To create a sub-stack, click the first entry in the “Track – Positions” window, then hold down the “SHIFT” 
key and click on the 13th entry.  This selects entries 1-13.  The “Image Viewer” will now display a sub-
stack generated from images 1-13.  At this point, you can now double-click on the object in the “Image 
Viewer” and create an observation by right-clicking and choosing “Create Observation” from the popup 
menu that appears.  Then, to create another observation using images 14-27, go back to the “Track – 
Positions” window and click on entry 14, then hold down the shift key, and click on entry 27.  Another 
sub-stack will be created, this time using images 14-27.  As before, you can double-click on the object in 
the “Image Viewer” and create an observation by right-clicking, and choosing “Create Observation” from 
the popup menu that appears.  Repeat once more with images 28-39 to create a third observation, if 
desired.  As mentioned in a previous example, these observations are added to the “Observations – 
Single Target” window.  You need click on the “Add to Target List…” button to move them over to the 
“Observations – All Targets” window. 
 
Tip: If you are wondering what the “Add Animation Stack” button does on the “Track – Positions” 
window, it simply adds another stack to the blink animation.  The blink animation is controlled by the 
“Blink Stacks” window, which is normally kept hidden.  If you want to bring it to the front, you can go to 
Window – Blink Stacks from the main menu. 
 
Another feature of the “Track – Positions” window is that it enables you to create a sub-stack in real-
time by clicking on an entry in the list and holding down the “SHIFT” key while pressing the “Down” 
arrow key on the keyboard.  You should see the “Image Viewer” update in real-time as the images are 
combined.  This is usually quite fast if you have “GPU Acceleration” enabled. 
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Example #5: Measuring a Faint NEO (with synthetic tracker) 
 
The purpose of this example is to show how you can detect and measure a faint NEO using the synthetic 
tracker.  Since the object is quite faint, many exposures are used.  And as the synthetic tracker is used, a 
minimum of 11 images are required. 
 

Step 1: Load and Process the Images 
 
This example uses the same dataset as the previous example, “ds2”.  Proceed to load and process the 
images (calibrate, align, and plate solve).  Refer to the first example for details on how to perform these 
steps. 
 

Step 2: Attach Ephemeris to the Dataset 
 
Similar to the previous example, you will retrieve observations of the object and use those observations 
to generate ephemeris information.  Then, attach that ephemeris to the dataset.  The object is again 
“2018 RB”.  Refer to the previous example for details on how to attach ephemeris information. 
 

Step 3: Run the Synthetic Tracker 
 
Navigate to Action->Synthetic Tracker from the main menu.  A new window will appear, prompting for 
the “Sensitivity Threshold”.  A setting of 50% works well here, but if the object is extremely faint you 
may want to increase the sensitivity.  A lower sensitivity can also be specified, resulting in faster 
searches at the tradeoff of sensitivity. 
 

 
Figure 46 - Sensitivity Threshold 

 
Proceed with the default of 50% sensitivity and click “OK” to continue. 
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On the next window, you are prompted for the search parameters.  Since this is a search of a known 
object, and since you have attached ephemeris information to the dataset, you can click the “Use 
Dataset Ephemeris” button to automatically confine the search to the motion of the object.  You should 
see that the speed and PA have been limited as shown in Figure 47. 
 

 
Figure 47 - Synthetic Tracker Configuration 

 
Click “OK” to start the synthetic tracker. 
 
If GPU acceleration is enabled, the tracker should complete after a few seconds; otherwise, it may take a 
minute or two. 
 

Step 4: Analyze the Tracks 
 
When the tracker has finished, the “Track Navigator” window should appear with a list of candidate 
detections (tracks).  Normally, the target of interest should be in the top 10 tracks, as they are sorted by 
“quality” by default.  In this case, it is track #1.  If a NEO you are searching for does not appear in the top 
ten tracks, you can search for it in the list by going to Find Object->By Ephemeris from the “Track 
Navigator” menu and it will sort the tracks by proximity to the expected location of the object as 
computed by its ephemeris.  Alternatively, you could also invoke Find Object->RA/Dec and input the 
coordinates manually.  In either case, the tracks will be sorted by proximity to an expected location.  
Note however that just because a track appears to be close to where the object is expected, does not 
mean that it is in fact the object.  You will have to perform either visual inspection or generate 
measurements that can be validated against other observations. 
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As the NEO was found in track #1, double-click track #1 to bring up the “Verify Track” window.  You 
should see the motion of the object in the “Image Viewer”.  At this point, you can proceed to generate 
observations, validate those observations, and generate a report, as described in previous examples. 
 

Step 5: Using Orbital Elements to find the NEO 
 
The first example described how to use the “Known Objects” window to locate objects based on their 
orbital elements.  This makes use of the “MPCORB.DAT” file published by the Minor Planet Center. 
 
Another way to find the NEO is to compute its orbital elements from the published observations, and 
then add those elements to the “MPCORB.CUSTOM” file, which is included in the regular search of the 
other asteroids. 
 
To do this, either download observations of the object or copy and paste observations from another 
source into the “Text Form – Observations” window.  If you want to download the observations, 
navigate to Tools->Download Observations from the main menu, specify “2018 RB” (without the 
quotes), specify “From obs database (confirmed object)”, and click “OK”. 
 
Once the “Text Form – Observations” window has been populated with observations of the object, you 
can then generate the orbital elements of the object and store them into the “MPCORB.CUSTOM” file by 
invoking Orbital Elements->Add to MPCORB.CUSTOM from the “Text Form – Observations” window.  
This invokes the Find_Orb program to compute the orbit, and after it has finished a new window will 
appear showing the objects stored in “MPCORB.CUSTOM”.  You can then save the result by going to File-
>Save from the menu of this new window.  It will present a message saying that the application must be 
restarted for changes to take effect; however, a shortcut around this is to go to Settings->Known Objects 
from the main menu and click the button labeled “Verify Database”, which will force a reload of the 
“Known Objects” database.  The reason this is not done automatically is because if you had previously 
loaded the database to perform matching with tracks in the “Track Navigator”, those matches will 
become invalidated upon a database reload. 
 
Having updated the “MPCORB.CUSTOM” file, you can now go to File->Load Known Objects from the 
“Image Viewer”.  You should now see two instances of the object shown in the “Known Objects” 
window.  The first instance is from the official “MPCORB.DAT” file, and the second instance (at the 
bottom of the list) is from the modified “MPCORB.CUSTOM” file. 
 
At this point, you can click on the entry in the “Known Objects” window that pertains to the object and a 
stack will automatically be created.  From this stack, you can then double-click on the object to center it 
in the crosshairs.  Then, right-click inside the “Image Viewer” and choose “Create Track – From Current 
Position”.  This will add a new track to the “Track Navigator” window.  As before, you can proceed to 
generate observations using this track information. 
 
If you want to remove the item from “MPCORB.CUSTOM”, go back to the “Text Form – Observations” 
window and choose Orbital Elements->Modify MPCORB.CUSTOM.  Then click on the item and press the 
“Delete” key, or right-click and choose “Delete” from the popup menu.  Then save the changes by going 
to File->Save from the menu of the “Orbital Elements [MPCORB.CUSTOM” window. 
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Step 6: Adjusting the Search Parameters 
 
By now you have learned how to find the NEO using several methods: 
 

1) Creating a Stack (using ephemeris information) 
2) Using the Synthetic Tracker (with ephemeris information) 
3) Using orbital elements (using known observations)  

 
All of the above approaches require some knowledge of the motion of the object.  However, the 
synthetic tracker can be used to find an object, even if its motion has large uncertainty. 
 
To try this, navigate back to Action->Synthetic Tracker and specify the same sensitivity threshold as you 
did earlier.  Then, on the last page concerning the “Synthetic Tracker Configuration”, try expanding the 
search as follows: 
 
Limit speed range: 1.50”/min to 2.50”/min 

   Limit PA range: 200 to 300 degrees 

 
This should result in approximately 4500 motion vectors. 
 
NOTE: If you specify an upper bound on speed that is larger than the “Max object speed” constraint, you 
will need to increase the “Max object speed” accordingly (using “Dataset ephemeris” automatically 
raises the “max object speed” constraint when necessary, but manual input does not). 
 
Click “OK” to start the synthetic tracker with this expanded search.  It may take several minutes, 
depending on your hardware configuration.  On a system with an NVIDIA RTX 2080, it took 19 seconds. 
 
When the tracker has finished, you will see the results shown in the “Track Navigator”.  The object 
should still be shown as track #1 as there are no other objects in this field with similar motion.  As the 
results indicate, the tracker was able to find the object even with a much wider search range.  This can 
be useful when the orbit of a NEO has very few observations, as you can open up the search parameters 
to account for the increased uncertainty. 
 

Example #6: Discovering New Asteroids with Synthetic Tracker 
 
This example demonstrates the primary use case of synthetic tracking, which is to discover new 
asteroids, comets, and other objects that are much fainter than could be detected with the conventional 
technique. 
 

Step 1: Load and Process Images 
 
This example uses the same dataset as the previous example, dataset “ds2”.  Proceed to load and 
process the images, applying the steps for calibration, alignment, and plate solving.  As usual, if you 
need a refresher on how to perform these steps, consult the first example. 
  

Step 2: Run the Synthetic Tracker 
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Once the images have been processed, navigate to Action->Synthetic Tracker from the main menu.  The 
window will prompt for a “Detection Sensitivity Threshold”.  The setting you choose here depends on 
how sensitive you want the tracker to be.  A setting of 100% is the most sensitive and will generate a 
large number of detections.  Conversely, a setting of 0% will generate almost no detections at all, save 
for the very brightest objects.  It is usually a good idea to allow some false detections to be generated, 
because that ensures you are detecting at a level that is sensitive enough to detect even the faintest 
objects.  To follow along with this example, use the setting of 50% and click “OK” to continue. 
 
Finally, you will be shown the “Synthetic Tracker Configuration” window. 
 

 
Figure 48 - Synthetic Tracker Configuration 

 
The first parameter, “Max object speed”, determines the overall constraint on the search space.  By 
default, it is computed by assuming an object could move as fast as four pixels per exposure (a slight 
amount of streaking).  In other words, if you had a 120 second exposure, and a plate scale of 1.65”/pixel, 
it would set the default max speed to [1.65*60*(4/120)] = 3.3 arcsec/min.  In general, the default setting 
is usually adequate, but if you have a very fast object (or a very long exposure time), then you may need 
to adjust this setting. 
 
Under the “Advanced Settings” parameters you will find the ability to limit the search based on speed 
and position angle.  This is very useful if you already know the motion of the object.  You can also adjust 
the granularity of the motion vectors, with higher granularity resulting in more vectors to search.  A 
setting of 67% for granularity is almost always sufficient.  The “minimum shift between images” 
determines the threshold at which a shift is considered significant to warrant inclusion in the list of 
search vectors.  It acts as another level of granularity, with smaller values resulting in more vectors.  
Usually, the default value of 0.5 is sufficient.  Next, you have the ability to crop detection near the 
edges, a value of 30 to 60 is usually ideal. 
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Finally, you may want to enable multithreading to speed up the processing.  In CPU mode, this setting 
overrides the setting in the Device Selector, and the threading works by dividing up each image for 
processing.  In GPU mode, this setting works by having each thread operate on its own motion vector, 
and consequently there is some memory overhead as each thread allocates its own workspace.  In 
general, when in CPU mode, the number of threads should be set to the number of cores, whereas in 
GPU mode the number of threads should be just enough to keep the GPU busy, which may be only 3 or 
4 threads even on a large-core system.  This is where you will have to experiment to identify optimal 
settings for your particular system. 
 
Make sure that your settings match those in Figure 48.  Then click “OK” to begin the search. 
 
Because we are doing a “blind” search (meaning no limits on speed or PA), the number of motion 
vectors is rather high at 56,644.  Consequently, this dataset may take some time to process, particularly 
if GPU acceleration is not enabled.  On a system using an NVIDIA RTX 2080 graphics card, the total time 
to process was 242 seconds. 
 
You can see the performance of your system by going to Metadata->View in the “Track Navigator” 
window that appears after the processing has completed. 
 
It is recommended that before you do anything else, go ahead and save the results by going to File-
>Save Tracks in the “Track Navigator” window.  This way, you can easily revert back without having to 
run the tracker again. 
 

 
Figure 49 - Track File Metadata 

 
You will note that 1000 tracks were identified, as shown at the bottom of the “Track Navigator” window.  
As you can see, sensitivity of 50% is sufficient to detect the faintest objects.  If you were to re-run it with 
a sensitivity of 0%, you would see that only 13 tracks are returned in total.  Tracks at the top of the list 
are most likely to be valid, while those ranked farther down the list are more likely to be false 
detections. 
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Starting with v6.1, there is now an option to compute a “confidence” metric for each track, making it 
much easier to determine which tracks are true detections.  Navigate to Actions->Compute Confidence 
from the “Track Navigator” menu to try out the feature.  You can click “Cancel” at any time.  The 
confidence algorithm is very good at distinguishing real objects from random noise.  However, camera 
artifacts such as hot pixels can still appear as “real” objects due to their motion, so you will want to 
ensure that you have removed such artifacts from the images during calibration. 
 
Tip: If you still want to have high sensitivity, but do not want thousands of tracks returned, go to 
Settings->Tracker from the main menu and specify the maximum number of tracks to be returned. 
 

 
Figure 50 - Track Results 

 

Step 3: Analyzing the Tracks 
 
At this point you have a list of numerous tracks available to evaluate.  It would be quite tedious to 
examine them all in detail, so one task to carry out is to determine which tasks match up with an already 
known object.  To do this, go to File->Load Known Objects from the “Track Navigator”.  You will now see 
that most of the tracks in the first 20 entries are matched with a known object.  One of the tracks -- 
number 16 -- is an erroneous match, having an “ObjDist” value exceeding 1.0 arcminute, while the other 
matches have an “ObjDist” value under 0.3 arcminutes, indicating a good match.  Again, this is a 
configurable setting: you can set the match tolerance such that erroneous matches are less likely to 
appear.  However, some objects have higher uncertainty in their orbital elements, and so a higher 
tolerance is desired.  Finally, track #17 appears to be a potential discovery, as it does not match up with 
any known object.  So, in this scenario, you would proceed to create observations of that object by 
double-clicking on its track entry (or right-clicking on it, and choosing “Verify Track” from the popup 
menu that appears).  With the “Verify Track” window open, you should now see an animation of the 
track.  You can visually inspect the object by examining the animation in the “Image Viewer”. 
 
Tip: The animation is one way to verify that the object is real.  Another way is to scroll through the 
images in the “Track – Positions” window, which will present each image in the “Image Viewer” as you 
scroll down using the “Down” arrow key.  From this dialog you can also use the left and right arrow keys 
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to navigate to other tracks, which is much more convenient than going back and forth to the “Track 
Navigator” window. 
 
Proceed to create observations of this object by clicking the “Add Observations” button. 
 

 
Figure 51 - Matching Tracks with Known Objects 

 
As this is an unknown object, leave both the permanent ID and the provisional ID fields blank.  Only the 
“Tracklet ID” field should be populated, with an identifier of your choice (however, the computer-
generated identifier should normally work fine). 
 

Step 4: Using MPChecker to Determine if Object is “New” 
 
At this point, you have created observations of a potential discovery.  Now you will want to use the 
“MPChecker” tool to see if these observations might still match up with an already known object.  To do 
this, navigate to the following webpage and input the observations of the object into the web form: 
 
https://www.minorplanetcenter.net/cgi-bin/checkmp.cgi 
 
Click the radio button “these observations” and then click “Produce List”.  If the results come back with 
“No Known Objects”, or if there are objects but the offsets are all greater than 0.1, then it may well be a 
discovery.  Note that the MPChecker tool requires observations in MPC1992 format. 
 

Step 5: Taking Optimal Data for the Tracker 
 
As you look through the tracks in the list, you can see that the synthetic tracker does quite well at 
detecting very faint asteroids.  It even detected “2018 RB” in a fully blind fashion.  However, there are 
some limitations of the tracker to be aware of so that you can better understand how to optimize the 
data for it. 
 

https://www.minorplanetcenter.net/cgi-bin/checkmp.cgi
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For one, if your data has numerous “hot pixels” or other artifacts, then the tracker will produce subpar 
results.  This is because, although hot pixels may appear stationary on the un-aligned images, once the 
images have been aligned, the hot pixels (and other artifacts) can now appear to have motion from one 
image to the next.  So, for best results, use a good dark frame, or some other mechanism to suppress 
the hot pixels and other camera artifacts. 
 
Second, be sure to take data that matches the motion of the object you wish to detect.  If it is a very 
fast-moving object, use short exposures of perhaps 10 seconds or even shorter.  Otherwise, if the object 
is slow-moving, you could use longer exposures such as 30 or 60 seconds.  But most importantly, be sure 
that the total exposure time is long enough so that the object exhibits sufficient motion.  That is to say, 
you could get away with using 10 second exposures even on a very slow-moving object: so long as the 
total exposure time is long enough for the object to move at least 5 pixels, then the object should be 
detectable.  Generally, the first constraint for the tracker is the number of images, with a minimum of 11 
required.  And in fact, it is best to have at least 25 images, preferably 30-60 images (sometimes more).  
With CMOS cameras having low readout noise, you can usually get away with shorter exposures, and 
simply have more of them to reach the desired exposure count.  If you are unsure of what exposure 
times to use for a given object, navigate to Tools->Calculate Optimal Exposure Time from the main 
menu.  This window has its own “Help” file, which you can access by clicking on the “Help…” button. 
 

Example #7: Longer Total Exposure Dataset (with Synthetic Tracking) 
 
This example is very similar to the previous example, except that it has a longer total exposure time 
using 60 images. 
 

Step 1: Load and Process Images 
 
Proceed to load and process the images, performing calibration, alignment, and plate solving.  The 
dataset to use is that of “ds3”. 
 

Step 2: Run the Synthetic Tracker 
 
Navigate to Action->Synthetic Tracker.  Use sensitivity of 50%.  For the tracker configuration, do not 
apply any limit to speed or PA.  There should be 121,104 vectors to be searched.  Use crop of 60.  
Granularity of 67% (default).  Then click “OK” to start the tracker.  With the total time increased from 1.4 
hours to 2.2 hours, the tracker has to search a much larger number of trial vectors (from around 56k 
vectors to 121k vectors), so the processing time will also be increased.  On a machine equipped with an 
NVIDIA RTX 2080 GPU, it took around 348 seconds to complete. 
 

Step 3: Analyze the Tracks 
 
After the tracker has finished, you will note that it has found a total of 17 asteroids: the first 16 are rated 
“high” confidence, then another “Med” (medium) confidence at track #21.  Your track numbers may be 
somewhat different if the images were processed with a different alignment option.  Also, just because 
a track is rated with “high” confidence does not automatically mean that it is a true target, but it does 
help to narrow down which tracks need to be examined. 
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As you can see from these results, the additional dwell time and more exposures enabled the tracker to 
identify more asteroids, including 2008 WY119 which is at magnitude 21.  Note however that there are 
diminishing returns to the longer dwell time.  Especially with NEOs, where they will move out of the field 
of view more quickly and therefore become undetectable, or eventually introduce curvature in their 
motion.  You will have to determine the optimal dwell time for the type of target you wish to detect. 
 

Example #8: Using the Test Target Generator 
 
A more scientific way to evaluate the performance of the tracker with respect to different threshold 
settings is to inject a grid of “test targets” that have a known signal-to-noise ratio (SNR).  By running the 
tracker on identical data but with different threshold settings, it is possible to more easily quantify the 
detection performance. 
 

Step 1: Load and Process Images 
 
Load the images from “ds2” and proceed to process them by performing calibration, alignment, and 
plate solving. 
 

Step 2: Run the “Evaluate Thresholds” Module 
 
Navigate to Action->Evaluate Thresholds from the main menu.  Here you will see a new window appear 
with settings for “FWHM”, “SNR”, “Sensitivity”, and “Granularity”, along with a few other options. 
 
Specify the following settings: 
 

FWHM SNR Sensitivity Granularity 

Start Stop Step Start Stop Step Start Stop Step Start Stop Step 

2.5 2.5 0.5 0.6 0.8 0.1 20 45 5 20 45 5 

 
Also set FWHM to be in pixels, and enable the option “Compute magnitude of injected targets”.  Then 
click the “Start” button to start the process. 
 

Step 3: Analyze the Results 
 
After a minute the module will finish.  There should be three different magnitudes to examine since 
three sets of targets were injected (SNR=0.6, 0.7, and 0.8).  As you can see, detection of SNR=0.6 targets 
is quite minimal as these are simply too faint to be detected in just 39 images.  Detection of SNR=0.7 
targets is improved, and as expected, targets with SNR=0.8 are detected the best. 
 
You can hover the cursor over each grid element to see the exact detection performance for that 
combination of sensitivity and granularity.  At the lower-left corner, detection is worse due to having a 
low sensitivity (20%) and granularity (also 20%).  At the top-right corner, detection is best due to having 
higher sensitivity (45%) and granularity (also 45%).  But the trade-off in increased sensitivity is 
processing time and number of false detections (which are partly mitigated via the “Compute 
Confidence” routine). 
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Figure 52 - Detection with 39 Images 

 
 

Step 4: Compare with only 13 Images 
 
The previous step demonstrated that it is possible to detect 92 out of the 100 injected targets at 
SNR=0.8, which corresponds to approximately magnitude 20.2 on these images.  Now, re-run the 
evaluation routine again, but this time use only the first 13 images.  You should see a noticeable 
reduction in detection, as shown in Figure 53: 
 

 
Figure 53 - Detection with Only 13 Images 

 
With only 13 images, detection was reduced to 45 out of the 100 targets, using the same thresholds of 
sensitivity=45% and granularity=45%.  As you can see, there is indeed quite a difference in detection 
capability with respect to the number of exposures. 
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Cluster Computing 
 
A single computer (or graphics card) may take a few hours to conduct a full “blind search” of a dataset.  
If it is desired to expedite the search process, Tycho offers the ability to divide the workload among 
multiple compute nodes.  In this hierarchy there is one primary node and one or more worker nodes.  
The worker nodes can be configured by installing Tycho on each node and going to Network -> Manage 
Worker Nodes for this Machine from the main menu. 
 

 
Figure 54 – Local Worker Node Configuration 

 
Figure 54 shows the local configuration for a single machine that has four GPUs.  Each GPU is assigned a 
device index and port number.  After adding the worker nodes to the list, you can then click the button 
“View Command Line Syntax” to see an example batch file script that could be used to launch the 
worker nodes from the command line.  Alternatively, you could launch them from this dialog box by 
clicking the “Launch Worker Nodes” button. 
 
New in v7.4 is the ability to use CPU, rather than GPU, worker nodes.  Simply leave the box for GPU 
acceleration unchecked, and the worker node will instead rely solely on CPU performance.  This may be 
useful for those who do not have access to GPU hardware. 
 
Once you have configured the desired worker nodes, you must instruct the primary node to use them.  
This is achieved by going to Network -> Manage Worker Nodes for Cluster.  Refer to Figure 55. 
 



 

56 
 

 
Figure 55 - Managing Worker Nodes 

 
Initially there are no worker nodes.  Click the “Add…” button (located in the lower-right corner) to add a 
new node, and specify the hostname and port number.  You should also specify a name for the node.  
Then click “OK” and you will see the node appear in the list.  In Figure 55 you can see that four nodes 
were added, one for each of the worker nodes configured in the previous step.  You can view 
information on each node by clicking the “Ping Nodes” button. 
 
If you need to clean up disk usage on a node you can click on “View Selected Node…” and a file browser 
will be presented.  You can delete files and folders here.  However, this is generally not necessary as the 
files are cleaned out at the start of each tracker run. 
 
Having specified at least one worker node, Tycho will now display a cluster configuration screen when 
you run the synthetic tracker.  By default, it will show the primary node (Local machine) and also the 
worker nodes that you added earlier.  If you wish to exclude a node from being used, you may select it 
and click “Deallocate Selected”.  This will move the selected node to the list of “Unallocated Nodes”.  
The tracker will only run on the nodes shown in the “Allocated Nodes” list.  For example, if you 
deallocate the primary (local machine) node, then the tracker will only run on the worker nodes. 
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Figure 56 - Cluster Configuration 

 
Once you have configured the cluster as desired, click the “OK” button to proceed. 
 
The next screen that appears is the “Cluster Status” screen, refer to Figure 57.  On this screen you are 
presented with the list of nodes on which the tracker will run (the allocated nodes from earlier).  Be sure 
that all nodes have returned a status of “Ready”, and then click the “Start” button to initiate the cluster 
processing routine. 
 

 
Figure 57 - Cluster Status 
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As each node processes the data, you will see the status of each node shown in the “Status” column.  
Refer to Figure 58. 
 

 
Figure 58 - Node Progress 

 
In this example, because each node is running an equivalent GPU, they each have almost identical 
progress.  Note that there are some circumstances in which it does not make sense to use multiple 
GPUs, such as when one GPU is more than twice as fast as another.  In that case, the other GPU would 
simply cause the overall processing time to increase since the workload is distributed evenly between 
the fast and slow GPU.  In general, no single node should be more than N times as fast as any other 
node, where N is the number of nodes. 
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Express Mode 
 
Tycho can also combine the processing steps (calibration, alignment, and plate solving) into a single step 
through the Express Mode feature. 
 
Check the box next to each step to indicate whether or not to perform that particular step.  Settings for 
each step are applied by clicking the “Settings…” button next to the step and specifying the relevant 
configuration.  See Figure 59 for details. 
 
 

 
Figure 59 - Express Mode 
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Auto Run (Scripting) 
 
Tycho offers the ability to process a set of files from the command line or through a batch script.  This 
feature is called “Auto Run” and operates on a set of pre-defined settings which can also be overridden 
through the use of an “override” file. 
 
In order to use the Auto Run feature, first navigate to Settings -> Auto Run from the main menu.  You 
will see a new screen appear as shown in Figure 60.  The runtime settings determine the behavior of the 
auto run module, such as whether or not it will perform the steps indicated by “Express Mode”.  You can 
also specify the contrast and intensity levels for the generated snapshot images.  The “Advanced 
Settings” are similar to those discussed in the earlier section covering the synthetic tracker.  
 
 

 
Figure 60 - Auto Run Settings 
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Once you have configured the desired settings for Auto Run, click “OK” to save the settings.  Then, you 
can open a command window and issue a command to Tycho in the following format: 
 
Usage: <tycho> <mode> <image directory> [override file] 

<tycho> = tycho executable 

 <mode> = 1 

          <image directory> = path to input directory 

            [override file] = path to override file (optional) 

 
As an example: 
"C:\Program Files\Tycho\Tycho.exe" 1 "C:\Users\Daniel\Desktop\iTelescope\data\pipeline\r1" 
 
The above command will launch Tycho in auto run mode and process the files located in the ‘r1’ 
subdirectory. 
 
Another way to use the Auto Run feature is to create a batch file, such as “auto_run.bat”, which 
provides the path to Tycho and a default image directory.  One might then simply replace this directory 
whenever a new set of images are to be processed. 
 
Finally, there is also the ability to create and use an override file.  An override file will, as its name 
implies, override the settings that you specified earlier.  To create an override file, you can click “Create 
Override File…” from the lower left corner of the window as shown in Figure 60.  Then, copy and paste 
the text into a new text file and save the file as “override.txt” adjacent to the input directory of images.  
In other words, the override file should be placed in the same directory as the image directory, not 
inside the image directory itself.  In this fashion, you can then write a script to update the override file as 
desired and the tracker will run accordingly. 
 
Starting with version 6.2, it is now possible to specify the path to the override file as the last argument in 
the command line invocation. 
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Pseudo-Flat Calibration 
 
Version 3.0 of Tycho introduces a way to process raw images with a ‘pseudo-flat’ technique.  The 
resulting images are both flat and also normalized with a consistent background level.  In other words, if 
you perform pseudo-flat calibration, then you will not need to perform the ‘normalization’ step.  
 
To perform this calibration, go to Action->Calibrate Images.  For “Flat Frame”, specify “Use pseudo flat”, 
and then click the “Settings…” button to adjust the settings as desired (usually the defaults are ideal). 
 

 
Figure 61 - Image Calibration 

 
By default, a window width of 41, with three passes (3), and an order statistic of 33% is ideal.  You may 
also specify a new background level or maintain the existing background level. 
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Dataset Ephemeris 
 
Another new feature for v3.0 is the ability to directly attach object ephemeris to each image.   This can 
be useful for those performing NEO confirmation, as an initial starting point in determining what motion 
vector(s) to use in finding the object. 
 
First, go to Tools->Download Observations from the main menu.  Then type in the object name, and 
choose whether or not to retrieve the data from the NEOCP list or from the Observations database: 
 

 
Figure 62 - Download Observations 

 
If the object has been confirmed, then it will no longer be on the NEOCP list, and you will have to choose 
“From obs database (confirmed object)”. 
 
Now click “OK” and the observations of the object will be shown (it may take a moment to retrieve the 
data from the MPC server). 
 

 
Figure 63 - Downloaded Observations 
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At this point, you can click “View in Find_Orb”, and the modified version of Find_Orb 
(find_o64_modified.exe) will be invoked.  If you do not have this modified version, please refer to the 
downloads section on the Tycho website.  Next, while keeping Find_Orb running in the background, 
navigate back to the “Image Manager” and choose Ephemeris->Attach to Dataset.  The ephemeris 
information of the object is now applied to each image listed in the “Image Manager”. 
 
At this point, assuming all went well, you should see the columns in the “Image Manager” populated 
with ephemeris information for each image.  Particularly useful is the “EPH_IN_FOV” column, which 
indicates whether or not the object is expected to be within the field of view of the image. 
 
For those images in which the object is not within the field of view, it is advised to remove them from 
the dataset as they will simply degrade the resulting stacks and measurements.  To do so, select the 
images, and then choose List->Remove Selected from the “Image Manager” menu. 
 
Another reason why the dataset ephemeris is helpful is that it can be used to provide an initial starting 
point for conducting the search of an object.  For example, in the configuration for the synthetic tracker, 
you can click “Use Dataset Ephemeris” (located near the top-right), and it will then update the limits for 
speed and position angle accordingly. 
 
While this will work for 99% of objects, sometimes a very new discovery that has only a few 
observations may not have a well-defined motion, so be careful when using the dataset ephemeris too 
strictly.  It may be necessary to open the search space, particularly for the speed.  For example, on 
object “2019 RC”, the dataset ephemeris suggested that the object was moving between 4.04”/min and 
3.59”/min, when in truth, the correct motion was around 3.18”/min.  Had the dataset ephemeris been 
used directly, the object would not have been found.  The solution is to widen the search space for such 
objects where the orbit is not yet well-known. 
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Repositories 
 
New in v5.0 is the concept of repositories, which provide a convenient way to store observations.  For 
example, one repository might be associated with ‘interesting’ objects for further follow-up, while 
another repository might simply store all observations collected to-date.  There are also two repositories 
created for the purpose of storing “Near-Earth Object Confirmation Page” (NEOCP) objects and the 
“Recently Confirmed” objects published by the Minor Planet Center (MPC). 
 
One use case for the latter two repositories is to determine if an object you found matches up with an 
object listed on the NEOCP or the “Recently Confirmed” page.  In other words, while the “MPChecker” 
tool (mentioned earlier) does a good job at identifying known objects from a set of observations, it does 
not check recently confirmed objects (nor objects on the NEOCP page), so it is helpful to have another 
tool that can do so.  Searching for such a match is achieved through the use of the “Object Linker” tool, 
accessible via Tools->Identify Linkages and covered in a later section. 
 
Repositories can be accessed via Tools->Manage Repositories from the main menu. 
 

 
Figure 64 - Manage Repositories 

 

Saving Observations to a Repository 
 
Observations can be saved to the repositories through three different methods.  For the 
“NEOCP/Recently Confirmed” repositories, navigate to Actions->Download NEOCP/Recently Confirmed 
from the “Repositories” menu.  Another method is through the “Observations -- All Targets” window, 
where it is possible to save the observations via File->Export to Repository.  Doing this will group the 
observations by object and save each object as a text file to the chosen repository.  The third method is 
through the “Text Form -- Observations" window, where the observations in the edit box can be saved 
to a repository via File->Save to Repository.  In this case, all of the observations in the edit box are saved 
to a single text file in the chosen repository. 
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Clearing a Repository 
 
For some repositories, it may be desirable to think of them as “temporary storage”.  Thus it is desirable 
to keep the repository itself, but not the items contained within it.  To clear out a repository, right-click 
on it and a context menu appears.  From this pop-up menu, choose “Delete Contents”.  The items in the 
repository are then removed, while the repository itself remains available for future use. 
 

Adding a Repository 
 
A new repository can be added by choosing “Add…” from the Repositories window. 
 

 
Figure 65 - Adding a Repository 

Removing a Repository 
 
A repository can be removed from the list of repositories by selecting it from the list and clicking the 
“Remove Selected” button from the Repositories window.  Alternatively, one could also right-click the 
repository and choose “Remove from List”.  Note that removing a repository simply removes it from the 
list – it does not delete the directory associated with the repository.  To empty the contents of a 
repository, follow the steps in “Clearing a Repository”.  To delete the actual directory itself, choose 
“Open in Explorer” and delete the directory. 
 

Refresh Repository List 
 
Most actions, such as adding or removing a repository, will automatically refresh the list of repositories 
as well as their associated object count.  However, if one were to manipulate the objects of a repository 
external to the Repository Manager (such as via Explorer), then the object count may be out of sync.  
Simply click the “Refresh” button and all repositories along with the associated object count will be 
refreshed. 
 

Viewing Items in a Repository 
 
There are two ways to view the contents of a repository.  One is to simply choose “Open in Explorer” 
which will reveal the standard directory window.  The other method is to click the “Open…” button 
while in the Repositories window, which will present a new window showing each item in the repository 
along with the number of observations, the arc length, and the date of first and last observation for each 
item.  While in this window, you can right-click on an object and choose “View” or “View in Find_Orb”.  
The first option, “View”, will copy the observations of the object to the text window (“Text Form – 
Observations”).  The latter option, “View in Find_Orb”, shows the observations in Find_Orb. 
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Figure 66 - Viewing Items in a Repository 

 

Identify Linkages 
 
Another new feature in v5.0 is the ability to identify linkages using a new “Object Linker” interface.  This 
module works alongside the new repository feature in that it allows one to simply specify a repository 
that contains the desired objects for link detection. 
 
As an example, consider the scenario of trying to determine whether or not a newly detected object is 
already listed on the NEOCP or “Recently Confirmed” page.  The first step is to update these repositories 
(discussed earlier) by going to Actions->Download NEOCP/Recently Confirmed via the “Repositories” 
window.  Once these repositories have been populated, they can then be used in the Object Linker tool.  
The next step is to then choose these two repositories as the “A” search path, and then choose the 
repository containing the newly detected object as the “B” search path.  Refer to Figure 67. 
 
Once the link process has completed, the results are shown in the “Link Results” window.  Up to 5 links 
are shown per each object, depending on the setting “Links per object”.  In this case, since there is only 
one object in the “B” search path, there are exactly five results shown for applied setting.  The results 
are sorted by median residual.  A median residual of one arcsecond or less (<1.00) is usually indicative of 
a possible link.  As shown in Figure 68, the object “DJP1001” links up with NEOCP object “P10XEUM”.  By 
right-clicking on the link, one can view each object as well the result of combining the observations of 
each object.  It is also possible to save the combined result to its own separate repository. 
 
Another scenario for the Object Linker tool is to determine what links, if any, exist between two nights 
of data from the same field.  For example, you might have wondered if an object you detected on the 
first night could really be found on the second night.  Normally, you would use ephemeris information 
and recover the object by setting the tracking parameters around that information.  But in the case 
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where you have perhaps dozens or more objects to confirm between the two nights, it can be easier to 
use the Object Linker tool. 
  

 
Figure 67 - Object Linker 

 

 
Figure 68 - Link Results 
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Continuing with this example, you would first proceed to create the relevant observations for the first 
night and store them in their own repository (e.g., “Night1”).  Then, do the same for the second night 
and store them in a repository, “Night2”.  Next, use the Object Linker tool (Tools->Identify Linkages) and 
specify “Night1” repository as Set A, and the “Night2” repository as Set B.  Run the linker, and examine 
the results.  For each link having an acceptable median residual (typically < 1.00), keep it in the list.  
Otherwise, if the link is not acceptable, delete it (right-click on the link(s) and choose “Delete”).  Once 
you have eliminated all invalid links, go back to the “Observations -- All Targets” window (or go to File-
>Load Observations if it is not currently available) and merge both nights of observations.  For example, 
if the Observations window is currently showing the observations from Night2, choose “File->Load 
Observations (Append to Existing)” and choose Night1 observations to be appended to the list.  Once 
the Observations window is showing the combined observations of both nights, and you have the “Link 
Results” window showing only the valid links between those two nights, you can then proceed to choose 
Observations->Apply Confirmed Links from the Observations window and this will give each object that 
has an associated link a shared designation.  Finally, if you want to eliminate the observations for which 
there is no confirmed link, you can choose Observations->Remove Unconfirmed. 
 

Image Statistics 
 
Another new feature for v5.0 is the ability to generate statistics for a given image, be it a single exposure 
or a stack of exposures.  These statistics can be generated by choosing File->Generate Stats for Current 
Image… from the “Image Viewer”.  It will prompt for the max number of stars to use, with 2000 being 
the default.  The stars are selected at random from the loaded catalog.  It is recommended to use the 
Gaia DR2 catalog to ensure reasonable depth of detection for images that reach past magnitude 18.  
Once you have specified the max number of stars, click “Start” and the tool will begin collecting statistics 
about the current image shown in the Image Viewer.  Again, this could be a stacked image – for 
example, by choosing “Selection->All” from the Image Manager, you would create a stack of all images.  
Or it could be a single exposure.  Either way, once the statistics have been generated, the results are 
shown in the Image Statistics window.  Refer to Figure 69. 
 
Note: Be sure that the image is not derived from tracked motion.  In other words, it must either be a 
single image, or a stack of images with zero motion applied (the stars should not be streaked). 
 

 
Figure 69 - Image Statistics 

 



 

70 
 

A number of fields are collected for each star in the image, including RA and Declination residuals, true 
magnitude versus calculated magnitude, flux, FWHM, and SNR.  Clicking on a row in the list will 
automatically navigate to the associated star in the Image Viewer.  It is also possible to generate plots 
for some of these fields from the “Plot” menu.  As an example, the “MaxRes vs Mag” plot will show a 
graph indicating the relationship between magnitude and max residual, with the fainter magnitude stars 
typically having a higher maximum residual (as expected).  Using this graph, it is also possible to get an 
idea of the limiting magnitude of the image, with the text in the lower-right corner indicating the % of 
data points satisfying the threshold at a given magnitude.  As an example, a single exposure from the 
dataset “ds2” is shown in Figure 70. 
 

 
Figure 70 - Plot of MaxRes vs Magnitude 

 
It is also possible to export the data to a CSV file by choosing File->Save to CSV from the “Image 
Statistics” window.  This enables additional work to be done on the data through other programs such 
as Excel. 
 
One particularly useful feature of the “Image Statistics” tool is the ability to easily determine if the 
image has a good plate solution attached to it, or has some other issue that would result in higher than 
acceptable residuals.  This can be accessed by going to Plot->Median Residual from the “Image 
Statistics” window.  From here, you have the ability to choose the number of divisions that comprise the 
grid.  In the dropdown labeled “Num divisions:”, choose “4” as the setting and you can see the image 
divided up into a 4x4 grid, which each cell indicating the residual for that region of the image.  An 
example of a dataset that has excellent residuals across the entire image is shown in Figure 71, whereas 
an example of a dataset with poor residuals is shown in Figure 72. 
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Figure 71 - Example of Dataset with Excellent Residuals 

 

 
Figure 72 - Example of Dataset with Poor Residuals 

 
In Figure 72, the grid indicates that the dataset tends to have acceptable residuals in the inner portion of 
the image, but poor residuals at the corners.  When inspecting the images of this dataset, the stars at 
the corners are shown to have very soft focus, while the stars at the inner region have sharp focus.  This 
matches well with the results shown in the grid.  In summary, you can use this tool to help validate both 
the quality of the images as well as the quality of the plate solution.  If either one has subpar quality, 
then that should show up in the grid display. 
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Constructing a Lightcurve 
 
Tycho also offers the ability to construct lightcurves and determine rotation periods. 
 

 
Figure 73 - Lightcurve of asteroid (1627) Ivar 

 

Step 1: Update the “Active Observatory” 
 
The datasets used by this example were captured by Platanus Observatory, which has MPC code “K80”.  
Navigate to Settings->Observatory from the main menu.  Then choose Action->Add Observatory from 
the menu of the “Observatory Configuration” window.  It will prompt for the observatory details.  
Specify “K80” (without quotes) for the “Label” field.  Choose “Already have an MPC code” for the 
observatory status.  Then specify “K80” (again without quotes) for the MPC code.  Click the button 
“Apply location from MPC code” to automatically populate the location information.  The “Telescope” 
field is not important for this example, but you can use the same settings as shown in Figure 74.  Then 
click the “Next…” button to continue to the next page. 
 
On the second page, make sure your settings match those shown in Figure 75.  Then click “Finished” to 
add the new observatory. 
 
Find the new observatory in the list.  Then right-click on it and choose “Make Active” from the popup 
menu that appears. 
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Figure 74 - Configuring Observatory 1/2 

 

 
Figure 75 - Configuring Observatory 2/2 
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Step 2: Load the “Ivar Night 1” Dataset 
 
Launch Tycho and navigate to List->Add Images from the “Image Manager”.  The images for this 
example are located in the “n1” subdirectory of the dataset labeled “Ivar Lightcurve”.  There should be a 
total of 123 images in this dataset, which is the first of three nights of data collected for this object. 
 

 
Figure 76 - The "Ivar_n1" Dataset with 123 Images 

 

Step 3: Perform “Express Mode” 
 
Navigate to Action->Express Mode and click the “Settings…” button located to the left of “Align”.  As 
there are a lot of images, you may want to choose the “Internal” option since it is very fast to process 
the 123 images.  Then, navigate to the “Internal” tab to configure the settings.  Ensure that the “Mode” 
is set to “Normal”.  Distortion correction is not required for these datasets (and would only increase the 
processing time), so leave it unchecked.  Then click “Save Settings” to continue. 
 

 
Figure 77 – Alignment Configuration 
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Figure 78 - Plate Solve Settings 

 
Finally, back at the “Express Mode” window, click the “Settings…” button located to the left of “Plate 
Solve”.  If you have not yet configured the plate solver, proceed to do so now.  Refer to the section 
labeled “Configure the Plate Solver” for details. 
 
Then, verify that your “Express Mode” settings match those shown in Figure 79. 
 

 
Figure 79 - Express Mode Settings 
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At this point, you should be ready to process the images for the first night (n1).  Click the “Start” button 
on the “Express Mode” window to proceed.  After a minute, the images should be aligned and plate 
solved. 
 
From the “Image Manager”, navigate to List->Add Images and load the images from the output 
directory, “n1_a”.  You should once again have approximately 120 images loaded, except this time they 
are now processed and ready for measurements to be created.  Before moving onto the next step, 
navigate to Action->View Images from the main menu. 
 

Step 4: Adjust the Apertures 
 
The default photometry apertures are 4.0 pixels for the inner annulus, 2.0 pixels for the dead-zone 
(region between inner and outer annulus) and 9.0 pixels for the outer annulus.  To adjust the apertures, 
choose Photometry->Modify Aperture Settings from the “Image Viewer” menu.  Here a new window will 
appear, where you can adjust the aperture settings.  You will also note that the crosshairs have changed 
to indicate the current aperture.  An optimal inner annulus will include most of the light from the target 
and a minor amount from the background sky.  When satisfied with the setting, click “Close”. 
 

 
 

Figure 80 - Adjusting Aperture Settings 
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As shown in Figure 80, I have adjusted the radius to be 5.8 pixels for the inner aperture and 2.9 pixels for 
the Dead zone.  It is also a good idea to click the button “Copy Target to Comp Star”, so that the 
comparison stars use the same aperture as that of the target object.  However, this is not necessary if 
the box labeled “Force comp stars to use same aperture as target” is checked.   Again, the optimal 
aperture should be determined by the target.  If you are working on a known asteroid, you can find it in 
the image by selecting File->Load Known Objects from the “Image Viewer”.  For variable stars, you can 
choose Photometry->Variable Stars from the “Image Viewer”. 
 

Step 5: Specify Comparison Stars 
 
New in v8.0 is the ability to manually specify which stars are used as comparison stars (comp stars) for 
the photometry measurements.  If you wish to have Tycho automatically choose comp stars, then you 
can skip this step.  Otherwise, proceed to navigate to Photometry->Find Comp Stars from the menu of 
the “Image Viewer”.  You should see a new window appear that resembles the one shown in Figure 81. 
 

 
Figure 81 - Identify Optimal Comparison Stars 

 
On the right half of the window there is a graph showing a trend line.  This indicates the relationship 
between instrument magnitude and true magnitude for each star that meets the filter specified in the 
left half of the window.  Ideally, the slope of this line would be 1.00 and the standard deviation (Std) 
would be 0.00, indicating a perfect fit of the data. 
 
One common reason for a larger deviation is if you have the “Max magnitude” filter set too high.  These 
exposures are only 2 seconds, so the default max of 20.0 includes a lot of very faint stars.  To remedy 
this, specify a lower value for “Max Magnitude” (such as 16.0) and then click the “Refresh” button.  The 
graph will update accordingly. 
 
You can also filter stars by solar temperature, specifying a desired lower- and upper-bound for (B-V).  
The Sun has a (B-V) value of around 0.6, and it is usually common to set the min and max to 0.5 and 0.9 
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respectively.  Alternatively, if you are working in (V-R), you could instead apply a filter for that range of 
temperatures.  The other filters work in a similar fashion with a min and max setting. 
 
The radius filter is a new option introduced in v8.1.  It allows one to filter the comparison stars by 
proximity to the marker position(s).  As an example, this might be useful if you wanted to select 
comparison stars that reside near the object.  To apply the filter, first create a marker by going to 
Create->Marker 1 from the “Image Viewer” menu, or right-clicking inside the image and choosing Create 
Marker 1 from the popup menu.  The marker will be created at the current location of the crosshairs.  
Next, click on the “Radius” checkbox to enable it, and then adjust the slider to set the desired radius 
from the marker.  If you create both marker 1 and marker 2, then the center of the circle will be defined 
as the midpoint of the two markers.  As an example, you might define marker 1 as being the first 
position of the object, and marker 2 as the last position of the object as it moves across the field.  As 
with the other options, click the “Refresh” button to update the filter. 
 
Each star that “survives” the resulting filter is then shown on the trend line as a red circle.  You can click 
on a red circle and Tycho will then center the star in the “Image Viewer”.  If you want to use the given 
star as a comparison star for photometry, you can then right-click in the graph and choose “Add to 
Active Comp Stars” from the popup menu that appears.  Alternatively, you could double-click on the star 
in the “Image Viewer”, right-click, and choose “Add to Active Comp Stars” from that popup menu.  Both 
approaches accomplish the same result. 
 
If you want to see more information about a star, double-click on it in the “Image Viewer” to center it, 
then right-click and choose “View Star Information” from the popup menu that appears.  This will 
present a new window as shown in Figure 82. 
 

 
Figure 82 - View Star Information 

 
Once you have an initial set of active comparison stars, you can navigate to Graph->Generate Data from 
the menu of the “Active Comparison Stars” window.  This will measure each comp star across all of the 
images and generate graph information for each one as shown in Figure 83. 
 
Be sure that “Graph->Computed Mag vs Time” is the current graph setting.  If not, navigate to Graph-
>Computed Mag vs Time to set the option.  For each comparison star, the graph shown on the right-half 
of the window should present a mostly flat, horizontal line of data points.  This indicates that the star 
has a consistent measured magnitude throughout all the images in the dataset.  If you see variability in 
the measured magnitude, then it is likely a good idea to discard it from the list.  This can be done by 
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right-clicking on the star in the list, and choosing “Remove Comp Star” from the popup menu that 
appears. 
 

 
Figure 83 - Active Comparison Stars 

 
It is usually common to choose around 5 to 7 comparison stars.  Once you are satisfied with the list of 
active comparison stars, then you are ready to make photometry measurements.  If you decide that you 
want to revert back to the “automatic” comp star selection, simply select all of the stars in the list, right-
click, and choose “Remove Comp Star”.  This will result in an empty list, and Tycho will assume that it 
therefore needs to identify its own set of comparison stars. 
 

Step 6: Generate Photometry Measurements 
 
The most straightforward approach to generating the measurements is to define two markers indicating 
the motion of the object.  For this example, go to the “Image Manager” and click on the first image in 
the list, so that the first image is shown in the “Image Viewer”.  Then, locate the asteroid in the view and 
double-click on it to center it.  If you are not sure where the asteroid is located, you could animate the 
frames, or you could attach ephemeris information and create a stack from ephemeris (refer to Example 
#4 earlier in this document).  A third option is to invoke File->Load Known Objects from the “Image 
Viewer” menu.  Be sure to click back on the first image if it is not selected.  Then, once the object is 
centered (by double-clicking on it), right-click and choose “Create Marker 1” from the popup menu that 
appears.  Next, choose the final image in the list (at the “Image Manager”), then locate the object in this 
last image.  Once again, double-click the object to center it, and then right-click and choose “Create 
Marker 2” from the popup menu.  At this point, you should now have two markers defined, indicating 
the motion of the object.  For objects that have no motion (such as stars), you would simply define both 
markers at the same location. 
 
Now that the markers have been defined, right-click in the “Image Viewer” and choose “Generate 
Photometry Set”.  Depending on the number of images, this can take a moment to generate the 
measurements.  Once finished, the set of measurements will be added to a new window, “Photometry 
Sets”.  It is also a good idea at this point to save your work, so proceed to File->Save to Repository from 
the “Photometry Sets” menu.  You will be prompted to specify a name for the entry.  In this example I 
chose “ivar_test” (without the quotes) for the name.  Then click the “Save” button to save the data. 
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From the “Photometry Sets” menu, navigate to Graph->Plot all Sets and you will see a new window 
appear with the raw plot of the data you have taken. 
 

 
Figure 84 - First Night of Data for (1627) Ivar 

 
In Figure 84, you can see the raw plot of the first night of data for Ivar.  If desired, navigate to Data-
>Settings from the menu of the “Lightcurve” window and validate that the settings are as you want 
them to be (such as Exclude Outliers).  If you ever need to delete data points, you can click and drag a 
rectangle selection around them, then right-click and choose “Delete” from the popup menu that 
appears.  Or, you can right-click on them in the “Photometry Measurements” list and choose “Delete” 
from that popup menu. 
 
If you made any changes to the data, you can save the photometry set again by going to File->Save to 
Repository from the menu of the “Photometry Sets” window.  You can overwrite the previous entry or 
create a separate entry. 
 

Step 7: Perform an Initial Period Search 
 
If you were to conduct a period search with just this first night of data, you might get lucky and find the 
correct period.  If you want to try, navigate to Period->Find Period from the menu of the “Lightcurve” 
window.  A new window, “Period Search” appears.  Make sure your settings match those in Figure 85 
and then click the “Find Period” button to proceed. 
 
You will note that from just this first night of data, the first candidate period is 2.36 hours, and the 
phased plot does not quite resemble a “bi-modal” curve (two valleys and two peaks).  If you click on the 
second candidate period, 4.74 hours, then the phased plot resembles a bi-modal period, which suggests 
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we are closer to finding the correct period.  Using additional data (from nights 2 and 3) you will see that 
the correct period of 4.795 hours will be found with no issue. 
 

 
Figure 85 - Period Search Settings 

 
As mentioned earlier, you can click on the different “candidate periods” to automatically refresh the 
phased plot display.  These candidate periods are shown in the “Period List” window as indicated in 
Figure 86. 
 

 
Figure 86 - Period List 

 
At this point you will want to include additional data for the period search.  You will also want to use 
lighttime correction (LTC) and (H-G) correction.  These steps are explained below. 
 

Step 8: Include Nights 2 and 3 
 
The previous steps showed how to process the data for the first night.  Now we want to do similar and 
include nights 2 and 3 as additional photometry sets for this repository.  The data for these nights are 
located in “ivar_n2” and “ivar_n3”.  Go ahead and create observations of the asteroid for night 2.  If the 
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resulting photometry set window contains only night 2, you can append night 1 by going to File->Load 
From Repository and choosing the repository you created earlier. 
 
Proceed to save your progress by going to File->Save to Repository from the “Photometry Sets” menu.  
As before, you can overwrite the previous entry. 
 
Now, as you did for night 2, do the same for night 3, so that you have three photometry sets. 
 

 
Figure 87 - Three Photometry Sets 

 
Once you have the three photometry sets shown in the “Photometry Sets” window, you will want to 
apply object data to them.  What this does is compute the Phase, Altitude, PABL, PABB, and Absolute 
Magnitude for every single observation.  To do this, select the three sets, then right-click and choose 
“Apply object data” from the popup menu that appears.  If you are not working with a minor planet, 
then you can skip this step. 
 

 
Figure 88 - Apply Object Data 

 
A new window will appear, “Apply Object Data”.  Here you can specify the number and name of the 
object.  If the orbital elements of the object are not yet established (such as a newly discovered object) 
then you can choose the option “Apply from observations” and click “OK”.  In this example, the object 
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has number 1627, so you can specify that in the “Object Number” field and then click “Search”.  Then, 
click on the returned result and choose “Apply from selected object”, and then click “OK” to proceed. 
 
In the case where you might instead choose “Apply from observations”, you will be prompted for the 
Find_Orb instance associated with the object.  If you do not already have such an instance loaded, go to 
Tools->Download Observations from the main menu, and specify the object.  Then click “OK” to 
download the observations; a new window with the observations will appear.  Then click on “View in 
FindOrb”.  Navigate back to the “Select FindOrb Instance” window, and click the “Refresh” button to see 
the new instance appear in the list.  Select it and then click “OK” to proceed. 
 
After a moment, you should see the object data applied to each of the three photometry sets.  Your 
“Photometry Sets” window should now be similar to that shown in Figure 87.  Once again, save your 
progress by going to File->Save to Repository.  As before, you can save over the previous entry. 
 
Note: If you take several nights of data and find that a given night requires some sort of “offset” 
adjustment to match up with another night, you can either apply an automatic offset or a custom offset.  
For automatic offset, select the three photometry sets, right-click and choose “Auto offset (absolute)” 
from the popup menu that appears.  For a custom offset, select the set of interest, right-click and 
choose “Custom mag offset”.  For these three nights, no offset is required. 
 
Now, from the “Photometry Sets” window, navigate to Graph->Plot all Sets.  You will see a raw plot as 
shown in Figure 89.  Because object data has been attached to these sets, both lighttime correction 
(LTC) and (H-G) correction are applied by default.  You can check this by navigating to either the “LTC” 
menu (for lighttime correction) or the “Magnitude” menu (for “H-G” correction).  Using (H-G) correction 
is typically important when performing period analysis, as it normalizes the measurements across phase 
angle and distance.  Refer to https://www.britastro.org/asteroids/dymock4.pdf for more details on (H-
G) correction. 
 

 
Figure 89 - Raw Plot of 3 Nights 

https://www.britastro.org/asteroids/dymock4.pdf
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Step 9: Final Period Search 
 
Navigate to Period->Find Period from the “Lightcurve” menu.  Use the settings as shown in Figure 90. 
 

 
Figure 90 - Period Search Settings 

 
Click the “Find Period” button and you will notice that this time, with all three nights of data available, 
Tycho is able to find the correct period (4.795 hours) and also lists it as the first candidate.  It also 
displays a period spectrum, or “periodogram”, which is a graph showing the other possible periods 
throughout the search interval of 1-12 hours.  If you want, you can also re-run the period search using a 
different Fit order.  Figure 92 shows an example of a 9th order fit to the data.  Usually, 4th order is a good 
starting point, and you want to avoid “overfitting” the data. 
 

 
Figure 91 - Phased Plot of (1627) Using 3 Nights of Data 
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Figure 92 - Phased Plot using a 9th Order Fit 

 

 
Figure 93 - Periodogram of (1627) with Search Interval of 1-12 Hours 

 
You can also choose different styles for the graph.  As an experiment, navigate to Style->Classic from the 
“Lightcurve” window. 
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Figure 94 - Phased Plot using the Classic Style 

 
Step 10: Compare with Lightcurve Database 
 
As this is a known asteroid with several published rotation periods, it should be possible to determine if 
the period you identified is correct.  To do this, navigate to Tools->Lightcurve Database from the main 
menu.  Then, type “1627” (without the quotes) into the field next to “Search for”, and also check the 
box labeled “Whole word only”.  Then click the “Search” button.  It may take a moment as it has to 
access the online database. 
 
When the search has completed, there should be one result returned.  From this result you can 
determine several characteristics of the object, including its diameter, absolute magnitude (H), slope 
(G), albedo, period, and amplitude.  From this result it should indicate a period of 4.795 hours, matching 
the photometry result that was generated earlier. 
 

 
Figure 95 - Searching the Lightcurve Database 
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Step 11: Generate Observing Circumstances Table 
 
If you wish to publish your results in the Minor Planet Bulletin, you may need to generate the values for 
the “Observing Circumstances” table.  New in v9.0.6 is the ability to do so directly from the “Lightcurve” 
window. 
 

 
Figure 96 - Observing Circumstances Table Values 

 
As shown in Figure 96, the phase, PABL, PABB, and other relevant values for the observing 
circumstances table are computed and displayed for publication.  To access this window, navigate to 
File->Obs. Circumstances from the “Lightcurve” window.  Note that you need to have conducted a 
period search in order for the period, period error (P.E.), and other associated values to be computed. 

 
Step 12: Exporting ALCDEF Data 
 
At some point you will probably want to share your photometry data with others.  The ALCDEF format 
provides a standard way to do so.  Navigate to File->Export ALCDEF from the “Photometry Sets” window 
and you will be shown a window prompting for details on the observations.  When ready, click the “OK” 
button and the data will be exported to a text file.  Alternatively, you could also export the data via File-
>Export ALCDEF (use current metadata).  This option makes use of the metadata attached to each 
photometry set, which you will want to verify before using.  To verify the metadata, select a photometry 
set and then right-click and choose “View/Edit Metadata”. 
 
Also note that the orbit information returned by Find_Orb will be associated with that of the 
observatory referred to by the “MPCCode” column.  If the code is 247 (indicating roving observer), then 
it will use the “ObsLon” and “ObsLat” columns.  These columns are populated automatically when 
creating photometry sets from observations, but should you need to change them, you can edit the 
metadata by choosing “View/Edit Metadata” from the context menu that appears when right-clicking 
the sets.  The relevant keywords are shown in Table 1. 
 

Table 1 - Column to ALCDEF Keyword 

Column ALCDEF Keyword 

MPCCode MPCCODE 

ObsLon OBSLONGITUDE 

ObsLat OBSLATITUDE 

 
For more information on the ALCDEF keywords, and the ALCDEF format in particular, visit 
www.alcdef.org. 

http://www.alcdef.org/
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Step 13: Importing ALCDEF Data 
 
To import ALCDEF data, navigate to File->Import ALCDEF from the “Photometry Sets” window.  If the 
“Photometry Sets” window is not open, you can access it by navigating to File->Photometry Analysis 
from the main menu. 
 
Once you have imported data, you will note that it has no object data attached to it.  To apply object 
data, select the sets that are in the list and then right-click and choose “Apply object data”.  As before, 
you will be prompted for the Find_Orb instance that has computed the orbit for your object.  Once 
object data has been applied, you will then be able to use the various attributes such as Absolute 
Magnitude, PABL, PABB, and phase. 
 

Adjusting Magnitude Offsets 
 
New in v9 of Tycho is the ability to more easily adjust the magnitude offsets associated with each 
photometry set.  Magnitude offsets can sometimes be required when working with data taken several 
nights apart.  To experiment with this capability, load two or more photometry sets into the 
“Photometry Sets” window (see previous section) and then choose Graph->Plot All Sets from the menu. 
 
Hold down the left mouse button and then drag a rectangle around the data points to be adjusted.  
Upon releasing the left mouse button, the enclosed data points inside the rectangle will be highlighted 
with a red circle.  Next, right-click inside the plot area and a popup menu will appear.  From this menu 
you can choose to adjust the magnitude offset in increments of 0.1, 0.01, and 0.001 magnitude.  
Alternatively, you can instead use the keyboard shortcuts: key up, key down, along with holding down 
the SHIFT key (0.01 increment) or CTRL key (0.001 increment).  Refer to Figure 97. 
 

 
Figure 97 - Adjusting Magnitude Offsets 
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Generate Transformation Coefficients 
 
The Tycho software can be used to generate transformation coefficients.  These are useful if you wish to 
transform photometry data to the “Standard” system.  The primary motivation in doing so would be to 
compensate for differences in the spectral response of equipment between observers. 
 
First, you will need to supply a special set of images to Tycho.  These images should capture a “Standard 
Field”, such as M67 or NGC 7790.  A list of standard fields is available from the AAVSO website: 
 
https://app.aavso.org/vsd/stdfields 
 
Furthermore, at least two different filters should be used throughout the image set.  In this example, 
five filters are used: UBVRI.  The images should be taken such that the filters are switched out from one 
image to the next.  For example, one capture of UBVRI images, followed by another capture of UBVRI 
images.  For the ultraviolet (U) images, you may need to use a longer exposure. 
 
The procedure is documented as follows: 

1. Choose a Standard Field.  In this example, NGC 7790 is used.  If you want to follow along with 
this example, you may download these images from the Tycho website at the following URL: 
https://storage.googleapis.com/tycho_data-1/2/NGC7790_iTelescope_T11.zip 

2. Acquire images in each filter that you wish to use.  Note that you may want to take a longer 
exposure for the U filter since most equipment is not as sensitive in that filter.  This example 
uses 300 seconds for U and 60 seconds for the other filters. 

3. Process the images.  Start Tycho and choose List->Add Images from the “Image Manager” 
window.  For this example, five images (one for each filter) are added to the list.  Next, choose 
Action->Align Images from the main menu. 

4. Load the aligned images into the “Image Manager”.  Tycho saves the output images into a new 
directory with suffix of “_a”, adjacent to the original directory. 

5. Plate solve the images.  Choose Action->Plate Solve Images from the main menu. 
6. View the images.  Choose Action->View Images from the main menu. 
7. Open the “Standard Fields” window.  Choose Photometry->Standard Fields from the menu of 

the “Image Viewer”.  Since the images have been plate solved, Tycho will automatically indicate 
the standard stars in the field with an overlay of yellow rectangles.  See Figure 98. 

8. Open the “Generate Transforms” window.  Choose Photometry->Generate Transforms from the 
menu of the “Image Viewer”.  Refer to Figure 99. 

9. Select the desired filter for “Use Images having filter label”, and the corresponding “Designated 
Filter”.  Normally, these two selections will be identical, meaning that “B” filter label 
corresponds to B filter.  But some users may have a different label, such as “Blue”.  Adapt as 
needed to your specific system.  Once you have made the selection, click “Create 
Measurements”.  Repeat until measurements have been created for each filter. 

10. View and edit magnitude pairs as needed.  Choose Transforms->Generate from Measurements 
from the menu of the “Generate Transform Coefficients” window.  Refer to Figure 100.  A new 
window will appear with a list of measurements to the left and a plot of those measurements to 
the right. 

a. You should see a trendline and the relevant data points in the plot in the right half of the 
window.  If the plot is empty, then it is possible that none of the data points satisfy the 

https://app.aavso.org/vsd/stdfields
https://storage.googleapis.com/tycho_data-1/2/NGC7790_iTelescope_T11.zip
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“Min SNR” constraint (default of which is 50.0).  The other possibility is that there were 
no magnitude pairs found (such as B and V). 

b. If you see outlier data points in the plot, you can simply click and draw a rectangle 
around the data point(s) to form a selection.  Once you have selected the outlier 
point(s), right-click in the plot and choose “Delete”.  If you accidently deleted the wrong 
data point(s), you can restore them by clicking the button “Restore Deleted”.  Note that 
this will restore every deleted data point. 

c. To view different coefficient plots, adjust the selection shown in the “Horizontal” and 
“Vertical” dropdowns at the bottom-left of the window.  For example, the “Horizontal” 
dropdown allows one to specify a different magnitude pair (such as B-V or V-R).  
Meanwhile, the “Vertical” dropdown allows one to specify the coefficient for that pair.  
You can explore the different combinations, removing outliers as needed. 

11. Once you are satisfied with the data, you can then click the button labeled “Generate Transform 
Coefficients”.  This will produce a report containing the numbers for your transformation 
coefficients.  The text from this report can then either be copied and pasted into another view 
or, you can navigate to File->Save to save the report as a text file.  Refer to Figure 101. 

 

 
Figure 98 - Standard Field NGC 7790 
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Figure 99 - Create Measurements 

 

 
Figure 100 - Standard Magnitude Pairs 
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Figure 101 - Computed Transformation Coefficients 

 
Additional notes: 
 
For the (U-B) pair, it can be necessary to adjust the “Min SNR” filter to 25 (from the default of 50) in 
order to include a wider range of star colors.  This can be observed by the horizontal axis.  With SNR=50, 
it has a range from -0.5 to 0.3.  But with minimum SNR lowered to 25 (allowing more stars), the 
horizontal axis now ranges from -0.5 to 1.2 and results in a more comprehensive trendline.  
Alternatively, it could have been more optimal to take a longer exposure for the U filter, as 300 seconds 
was not quite sufficient. 
 
Measurements are created using the current aperture.  The aperture can be modified by navigating to 
Photometry->Modify Aperture Settings from the “Image Viewer” menu. 
 
While not shown in this example, it is also possible to use multiple exposures of each filter.  The process 
would involve capturing one set of exposures for each filter, followed by another set, repeating until the 
desired number of sets is acquired.  This can produce a trendline with more data points to work with. 
An example dataset can be downloaded here: 
 
https://storage.googleapis.com/tycho_data-1/2/NGC7790_iTelescope_T11.zip 
 

Session Planner 
 
Another new feature in v9 of Tycho is the Session Planner module.  This module permits one to easily 
identify when a given object will be visible and its corresponding location in the sky.  But more 
interesting is that it also works with both Find_Orb as well as the JPL Horizons interface.  As one 

https://storage.googleapis.com/tycho_data-1/2/NGC7790_iTelescope_T11.zip
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example, you could generate a session plan to determine when and where to look for the James Webb 
Space Telescope (JWST) from your particular observing location. 
 
To activate the Session Planner, navigate to Tools->Session Planner from the main menu.  Note that you 
may need to have the Pro license for this feature to work.  Next, navigate to Ephemeris->Attach from JPL 
Horizons from the menu of the Session Planner.  This will bring up the JPL Horizons interface, refer to 
Figure 102.  Here you can specify a spacecraft (such as JWST), an asteroid or comet, or any other object 
given by its Two-Line Element (TLE). 
 
In this example, we want to generate ephemeris for the James Webb Space Telescope.  So, choose 
“Major-body (including spacecraft)” from the dropdown menu located next to “Lookup Type”.  Then 
input the value “-170” (without quotes) into the Target ID field.  If you are unsure of the identifier 
associated with the major body that you wish to work with, you can navigate to Search->Major-body 
Lookup from the JPL Horizons Interface menu.  Refer to Figure 103. 
 

 
Figure 102 - JPL Horizons Interface 

 
This will bring up a new window initially populated with every single major-body listed (482 at the time 
of this writing).  To narrow it down to the object of interest, you can filter by “Name contains” or “Alias 
contains” in the two edit boxes at the bottom of the window.  For example, you could type “James” 
(without quotes) into the “Name contains” field and it would reduce the list to just that of the James 
Webb Space Telescope.  You will then notice that the “Ident” column is equal to -170 for this particular 
object.  Now that you have the identifier, you can specify it in the “Target ID” field in the interface 
window. 
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Figure 103 - Major-body Lookup for JPL Horizons Interface 

 
 

 
Figure 104 - Session Planner 

 
At this point, you have specified the “Lookup Type” to be that of Major-body, and the “Target ID” to be 
that of -170.  You would next proceed to navigate to Ephemeris->Attach to Session Planner from the “JPL 
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Horizons Interface” menu, but before doing so, you will want to update the “Start Date”, “Stop Date”, 
and “Step Size” fields located at the bottom of the Session Planner window.  Refer to Figure 104 for an 
example. 
 
Here you can see that the “Start Date” is March 7, 2022 and the “Stop Date” is March 9, 2022.  The 
“Step Size” is 10 minutes.  The dates are also in UTC time as indicated by the checkbox.  If you want, you 
can also specify the “Local time offset”, associated with your observing location.  If you unchecked the 
box indicating that the dates are in UTC time, then that offset will be applied to the start and stop dates 
for the request.  It will also be shown in the “Date (Local)” column.  Note that the time offset does not 
take into account Daylight Savings Time (DST) – it is just a simple time offset for convenience purposes. 
 
Once you are satisfied with the “Start Date”, “Stop Date”, and “Step Size” parameters, navigate back to 
the JPL Horizons Interface window and proceed to choose Ephemeris->Attach to Session Planner from its 
menu.  If all goes well, your planner window should resemble that as shown in Figure 104, with the list 
showing the coordinates of the object for each particular time and date.  You can also choose to enable 
a filter to reduce the results such that the list will only show coordinates whenever the object is above a 
certain altitude, and/or whenever the moon and sun are below a certain altitude. 
 
The Session Planner also works with Find_Orb, so if you have an object that is not available from the JPL 
Horizons Interface (perhaps a newly-discovered object), then you can still generate a session plan by 
choosing Ephemeris->Attach from Find_Orb from the Session Planner menu. 
 

Command Line Interface 
 
Various parts of the Tycho functionality can be accessed via the command line.  The following presents a 
list of such functions.  Future versions may also expand upon this list. 
 

AutoRun 
AutoRun requires three command line arguments, with an optional fourth argument 
Usage: <tycho> <mode> <path to image directory> [override file] 
<tycho> = Full path to Tycho executable 
<mode>  = 1 (for regular autorun) or 101 (for image subset autorun) 
<path>  = path to input directory 
[over]  = path to override file (will use 'override.txt' if not specified) 

 

Image Preview 
Image preview requires three arguments 
Usage: <tycho> <mode> <path> 
<tycho> = Full path to Tycho executable 
<mode>  = 3 
<path>  = path to image 

 

Debayer 
Debayer requires 5 arguments 
Usage: <tycho> <mode> <cpu> <input dir> <output dir> 
<tycho> = Full path to Tycho executable 
<mode>  = 12 
<cpu>   0=use existing settings, 1=force CPU mode 
<input dir> 
<output dir> 
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Calibration 
Calibration requires 9 arguments 
Usage: <tycho> <mode> <cpu> <dark_frame> <flat_frame> <normalize> <fix_pixels> <input 
dir> <output dir> 
<tycho> = Full path to Tycho executable 
<mode>  = 7 
<cpu>         0=use existing settings, 1=force CPU mode 
<dark_frame>  0=no dark, is file path=use that file, path is dir=select from dir 
<flat_frame>  0=no flat, 1=pseudo, is file path=use file, path is dir=select from dir 
<normalize>   0=no normalization, 1=perform normalization 
<fix_pixels>  0=do not fix hot pixels, 1=fix hot pixels 
<input dir> 
<output dir> 

 

Resize 
Resize requires 12 arguments 
Usage: <tycho> <mode> <cpu> <width> <height> <hcrop> <vcrop> <bin> <hdiv> <vdiv> <input 
dir> <output dir> 
<tycho> = Full path to Tycho executable 
<mode>  = 8 
<cpu>    0=use existing settings, 1=force CPU mode 
<width>  0=keep width unchanged; otherwise, specifies desired width 
<height> 0=keep height unchanged; otherwise, specifies desired height 
<hcrop>  0=no cropping in horizontal; otherwise, specifies desired horizontal cropping 
<vcrop>  0=no cropping in vertical; otherwise, specifies desired vertical cropping 
<bin>    1=1x1 (no binning), 2=2x2 binning, etc 
<hdiv>   1=no divisions, 2=divide by 2 in horizontal, etc 
<vdiv>   1=no divisions, 2=divide by 2 in vertical, etc 
<input dir> 
<output dir> 
Note: Desired dimension overrides crop amount. 

 

Align 
Alignment requires 9 arguments, with an optional reference index 
Usage: <tycho> <mode> <cpu> <num_threads> <interpolate> <align_mode> <dist_corr> 
[idx_ref] <input dir> <output dir> 
<tycho> = Full path to Tycho executable 
<mode>  = 9 
<cpu>         0=use existing settings, 1=force CPU mode 
<num_threads> = Number of threads to use for the alignment process 
<interpolate> 0=bilinear, 1=bicubic 
<align_mode>  0=fastest, 1=normal (do not use 'fastest' unless images are already mostly 
aligned) 
<dist_corr>   = Whether or not to apply distortion correction (0=no, 1=yes; only 
available if align_mode=normal) 
[idx_ref]     = Index (range of 0 to N-1) of the reference image (optional) 
<input dir> 
<output dir> 

 

Merge 
Merge requires 6 arguments 
Usage: <tycho> <mode> <num_threads> <max_delta_time> <input dir> <output dir> 
<tycho> = Full path to Tycho executable 
<mode>  = 10 
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<num_threads> = Number of threads to use for the merge process 
<max_delta_time> = Max amount of time (in seconds) between images to be considered a 
match 
<input dir> 
<output dir> 

 

Cross-Match 
Cross-match requires 5 arguments 
Usage: <tycho> <mode> <create_snapshots> <path_a> <path_b> 
<tycho> = Full path to Tycho executable 
<mode>  = 11 
<create_snapshots> 0=do not create snapshot images; 1=create snapshot images 
<path_a> = Full path to the root directory of the 'A' camera track files 
<path_b> = Full path to the root directory of the 'B' camera track files 

 
Object Linker 
Object Linker interface requires 7 arguments 
Usage: <tycho> <mode> <link_timeout> <num_threads> <dirs_set_a> <dirs_set_b> <path_out> 
<tycho> = Full path to Tycho executable 
<mode>  = 14 
<link_timeout> = Timeout, in seconds, for each link 
<num_threads> = Number of threads to operate during linkage 
<dirs_set_a> = Full path to file listing the directories for Set 'A' 
<dirs_set_b> = Full path to file listing the directories for Set 'B' 
<path_out> = Full path to output linker result 

 
Star Extractor 
Star Extractor interface requires 6 arguments 
Usage: <tycho> <mode> <downsample> <extract_mode> <path_in> <path_out> 
<tycho> = Full path to Tycho executable 
<mode>  = 15 
<downsample> = Downsample, from 1 to 10 (default of 2). 
<extract_mode> = 1=Standard, 2=Extended 
<path_in> = Full path to the directory containing subdirectories of .fits image files 
<path_out> = Full path to the output directory 
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Troubleshooting 
 
If you find that a window has an incorrect size, restart Tycho and navigate to Window->Reset Window 
Positions from the main menu.  Be sure to do this on a fresh launch of Tycho, prior to opening any new 
windows.  This will reset any previously saved window position information. 
 

Additional Resources 
 
This guide has covered the basics of how to use the Tycho software.  There are also tutorial videos on 
the website at https://www.tycho-tracker.com 
 
Finally, if you run into any issues or have questions or comments, please feel free to contact me using 
the “Contact” page on the website, or try out the new forum: 
 
https://groups.google.com/forum/#!forum/tycho-tracker 
 
 
 

https://www.tycho-tracker.com/
https://groups.google.com/forum/#!forum/tycho-tracker

